Permission error when running cerbot ceronly

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: certbot certonly

It produced this output: e[31mThe following error was encountered:
[Errno 13] Permission denied: 'C:\Certbot\log\letsencrypt.log'
Either run as root, or set --config-dir, --work-dir, and --logs-dir to writeable paths.e[0m

My web server is (include version):

The operating system my web server runs on is (include version): Server 2019 standard

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know): i dont know

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 1.14.0

Try running that same command from an administrative command prompt.

1 Like


I tried that - same result.

The error message is pretty clear:

The "fix"/"workaround" is also straightforward:

Have you tried all of that?


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.