Not secure Red https showing on new certificate (mixed content error)


#1

Please fill out the fields below so we can help you better.

My domain is: https://vista-commercial.co.uk

I ran this command: several fixed mixed content plugins

It produced this output: No change

My operating system is (include version): OSX 10.12.3

My web server is (include version):

My hosting provider, if applicable, is: TSO Host

I can login to a root shell on my machine (yes or no, or I don’t know): Above my pay grade

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): TSO Host own brand

I’ve checked at whynopadlock.com and got this error:
SSL verification issue (Possibly mis-matched URL or bad intermediate cert.). Details:
ERROR: no certificate subject alternative name matches


#2

You didn’t say whether you have actually installed Let’s Encrypt certificate, only that you tried some plugins to fix mixed content issues. The domain you quoted serves gridhost.co.uk wildcard certificate, so unless you have a certificate issued and properly installed for your domain, you will be getting this error.

https://sslanalyzer.comodoca.com/?url=vista-commercial.co.uk


#3

Hi
Yes I have installed a Let’s Encrypt certificate via my TSO Host control panel which has been confirmed both by TSO Host and whynopadlock.com.
Nick Garnett


#4

Well, according to the tests (Qualys, Comodo and even whynopadlock) your certificate is NOT installed. At least not installed correctly. Since as you said it is some specific control panel, your best bet is contacting support of your hoster. Though by the look of it, you might have to pay them for the installation:

https://www.tsohost.com/knowledge-base/article/596/can-i-install-a-third-party-ssl

NB: Note that they have indeed advertised LE support on some “cloud hosting” at https://www.tsohost.com/knowledge-base/article/1028/install-let-s-encrypt-on-the-cloud, but you didn’t specify the type of hosting you have with them, so again - contact TSO support directly.


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.