No valid IP addresses found for

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain

I ran this command: sudo certbot --apache --email -d --agree-tos --redirect --noninteractive

It produced this output:
Type: None
Detail: No valid IP addresses found for

  • Your account credentials have been saved in your Certbot
    configuration directory at /etc/letsencrypt. You should make a
    secure backup of this folder now. This configuration directory will
    also contain certificates and private keys obtained by Certbot so
    making regular backups of this folder is ideal.

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:godaddy

I can login to a root shell on my machine (yes or no, or I don’t know):yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

1 Like

Your domain’s IP addresses are in a private range. Let’s Encrypt can’t connect to those addresses to confirm your control of your domain, which is why you see the error.

Your other option is to use DNS validation to issue the certificate. For this, you need to use an ACME client that supports DNS validation via GoDaddy.

For example, can do this:

Certbot doesn’t support GoDaddy for DNS validation out of the box, but it does support a manual workflow (no automated renewal):

certbot -i apache -a manual -d --preferred-challenges dns

You can also read about the different validation methods here:


Failed authorization procedure. (dns-01): urn:ietf:params:acme:error:dns :: DNS problem: NXDOMAIN looking up TXT for


  • The following errors were reported by the server:

    Type: None
    Detail: DNS problem: NXDOMAIN looking up TXT for

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.