Certbot acme challenge failure

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:yogi.paulx2.uk

I ran this command: sudo certbot --apache

It produced this output:
IMPORTANT NOTES:

My web server is (include version): 2.4.41

The operating system my web server runs on is (include version): Linux Mint 20.1 (Ulyssa)

My hosting provider, if applicable, is: one.com

I can login to a root shell on my machine (yes or no, or I don't know): Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):
no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 1.12.0

1 Like

Hi @pnewbery

if you have such an error, normally your Apache configuration is buggy.

What says

apachectl -S
2 Likes

Output from apachectl -S:

VirtualHost configuration:
*:443 yogi.paulx2.uk (/etc/apache2/sites-enabled/default-ssl.conf:2)
*:80 is a NameVirtualHost
default server yogi.paulx2.uk (/etc/apache2/sites-enabled/000-default.conf:1)
port 80 namevhost yogi.paulx2.uk (/etc/apache2/sites-enabled/000-default.conf:1)
port 80 namevhost yogi.paulx2.uk (/etc/apache2/sites-enabled/nextcloud.conf:1)
alias paulx2.uk
ServerRoot: "/etc/apache2"
Main DocumentRoot: "/var/www/html"
Main ErrorLog: "/var/log/apache2/error.log"
Mutex rewrite-map: using_defaults
Mutex ssl-stapling-refresh: using_defaults
Mutex ssl-stapling: using_defaults
Mutex ssl-cache: using_defaults
Mutex default: dir="/var/run/apache2/" mechanism=default
Mutex mpm-accept: using_defaults
Mutex watchdog-callback: using_defaults
PidFile: "/var/run/apache2/apache2.pid"
Define: DUMP_VHOSTS
Define: DUMP_RUN_CFG
User: name="www-data" id=33
Group: name="www-data" id=33

1 Like

There

is your buggy configuration.

Every combination of port and domain name must be unique.

1 Like

OK, Thanks Juergen, I am uncertain as to how this has happened as I only have one VirtualHost defined. However the 000-default and default-ssl sites are enabled. I don't seem to be able to get my head around how the apache VHosts setup is working.
I'll have a poke around and see what I can see!
Cheers
Paul N.

1 Like

Ok, so I have disabled the 000-default and default-ssl sites and all is now working as expected.
Thanks for pointing me in the right direction, although I feel that maybe that's a bit of of a drastic solution.
If it works, what the heck!
Paul N.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.