Acme Challenge issue-Certbot Apache

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: www.learninggardenmontessori.ph

I ran this command: $ sudo ln -s /snap/bin/certbot /usr/bin/certbot
$ sudo certbot --apache

It produced this output:Which names would you like to activate HTTPS for?
We recommend selecting either all domains, or all domains in a VirtualHost/server block.


1: www.learninggardenmontessori.ph


Select the appropriate numbers separated by commas and/or spaces, or leave input
blank to select all options shown (Enter 'c' to cancel): 1


An RSA certificate named www.learninggardenmontessori.ph already exists. Do you
want to update its key type to ECDSA?


(U)pdate key type/(K)eep existing key type: U
Renewing an existing certificate for www.learninggardenmontessori.ph

Certbot failed to authenticate some domains (authenticator: apache). The Certificate Authority reported these problems:
Domain: www.learninggardenmontessori.ph
Type: unauthorized
Detail: 2606:4700:3033::ac43:99cb: Invalid response from http://www.learninggardenmontessori.ph/.well-known/acme-challenge/aBad3aV3SHxUgHV6ibfKqZHe9oywq4ND03ZESPbAVtc: 523

Hint: The Certificate Authority failed to verify the temporary Apache configuration changes made by Certbot. Ensure that the listed domains point to this Apache server and that it is accessible from the internet.

Some challenges have failed.
Ask for help or search for solutions at https://community.letsencrypt.org. See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.
$

My web server is (include version): Apache -Apache/2.4.41 (Ubuntu) Server

The operating system my web server runs on is (include version): Ubuntu

My hosting provider, if applicable, is: Just an on premise

I can login to a root shell on my machine (yes or no, or I don't know): Yes I can root

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 2.5.0

PS: before this happened, it was already working, but i installed which is my mistake a certbot for nginx, and after that i cannot put it back to how it was,
Thank you so much,, i have been seeking help from the past, and you have been helping me - I really do appreciate it.

Hi @archimedes7,

Your site is behind the Cloudflare CDN. Cloudflare is showing that your origin (backend) web server is not accessible at all. Do you know why that is? Can you get the backend web server up again? If not, can you identify an error condition on the backend web server that prevents it from running?

2 Likes

oh, let me check that right now, I am trying to reconfigure things, that might have been the issue - thank you so much for the response. - additionally, if I am on vpn because i want to use port forwarding, will i have a problem running the lets encrypt? Thank you @schoen

1 Like

Possibly. The --apache option you chose uses the HTTP Challenge. The Let's Encrypt Server must reach you with HTTP on port 80 to check your control of that domain. Why do you need a VPN for port forwarding? Couldn't use just proxy from Apache?

You are no longer behind the Cloudflare CDN but HTTP requests to your domain still fail. The Let's Debug test site is helpful to test communications configuration.

If you later plan to keep your Apache server behind Cloudflare there are other options for you. One might be using their Origin CA Cert. It might be easier than using Certbot to get the cert. The Cloudflare docs and community are excellent sources of info.

2 Likes