Certbot certificate failed


I have tried applying new certbot certificate but failed. Can you help me?

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:


I ran this command:

certbot certonly -w /data/www/ --agree-tos --email dtakimi@aa.com.tr -d environment.aa.com.tr

It produced this output:

Saving debug log to /var/log/letsencrypt/letsencrypt.log

How would you like to authenticate with the ACME CA?

1: Apache Web Server plugin (apache)
2: Spin up a temporary webserver (standalone)
3: Place files in webroot directory (webroot)

Select the appropriate number [1-3] then [enter] (press 'c' to cancel): 3
Requesting a certificate for environment.aa.com.tr

Certbot failed to authenticate some domains (authenticator: webroot). The Certificate Authority reported these problems:
Domain: environment.aa.com.tr
Type: unauthorized
Detail: Invalid response from http://environment.aa.com.tr/.well-known/acme-challenge/GcN5DSHuNVyBtE9eypTuT-qY3wTnKuwE83PdLM-bB5k: 503

Hint: The Certificate Authority failed to download the temporary challenge files created by Certbot. Ensure that the listed domains serve their content from the provided --webroot-path/-w and that files created there can be downloaded from the internet.

Some challenges have failed.
Ask for help or search for solutions at https://community.letsencrypt.org. See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.

My web server is (include version):

Server version: Apache/2.4.37 (AlmaLinux)
Server built: Jun 22 2022 07:12:01

The operating system my web server runs on is (include version):

AlmaLinux release 8.6 (Sky Tiger)

My hosting provider, if applicable, is:


I can login to a root shell on my machine (yes or no, or I don't know):


I'm using a control panel to manage my site (no, or provide the name and version of the control panel):


The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):
certbot 1.22.0

1 Like

Fixed! it's a firewall issue.
Thank you


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.