No account exists with the provided key

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:
tried to renew a certificate using let's encrypt extension for Azure web app.

It produced this output:
[AcmeRequestException: Fail to load resource from ''.
urn:ietf:params:acme:error:accountDoesNotExist: No account exists with the provided key]

Staging Cert has worked. Certs for other domains (the same account) have also worked.

My web server is (include version): Azure WebApp

The operating system my web server runs on is (include version):
OS version: Microsoft Windows NT 10.0.14393.0

My hosting provider, if applicable, is:
Microsoft Azure

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

1 Like

Hi and welcome to the community forum!

Well there is definitely something wrong with your system.
It seems to be creating a new cert every day:

Perhaps it was not installed completely/correctly.
I would try to remove it and reinstall it first.
Then test it against the staging environment until it works correctly before switching to production.

[&2* readers: Get involved; Be heard. It starts with: if you read something you like, then like it :heart:]

1 Like

Hi, the problem is that I reinstalled it today and tested the staging, which worked fine, and after switching to prod. I got the mentioned error.


OK, I think the problem may be that the staging and production systems both issues accounts.
But they are NOT interchangeable; prod accounts only work in prod, staging accounts only work in staging.
And you're now using a staging account against a prod system.
I'm not too familiar with your client, but I would look through the docs to see how to replace the account in use.

[&2* readers: Get involved; Be heard. It starts with: if you read something you like, then like it :heart:]

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.