Nextcloud at home

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: I run nextcloud at home, I can point a web browser at the IP,, I get my domain from From the IP I can get the nextcloud web page. When I point a webpage at the page does not load, just times out. I used the guide at Nextcloud: Full Setup & Implementation Guide – LearnLinuxTV

It produced this output: When I point a webpage at the page does not load, just times out.

My web server is (include version): Apache 2 w/ php 7.4 to use Nextcloud Hub 2

The operating system my web server runs on is (include version): Debian 11

My hosting provider, if applicable, is: self-hosting

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no, shell access

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 1.26.0

1 Like

Hi @LarcHive, and welcome to the LE community forum :slight_smile:

HTTP connects and returns an HTTPS redirection (this is good):

curl -Ii
HTTP/1.1 301 Moved Permanently
Date: Sun, 10 Apr 2022 15:02:23 GMT
Server: Apache/2.4.53 (Debian)
Content-Type: text/html; charset=iso-8859-1

But HTTPS is not responding.

curl -Ii
curl: (7) Failed to connect to port 443: Connection timed out

Ensure port 443 is open and follows the same path port 80 does.

Also, since I see Apache, check that all is well there too.
Start with:
apachectl -t -D DUMP_VHOSTS


Thank you! I did not have port forwarding for 443 turned on.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.