Newbie trying to understand

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: Not sure. I just started receiving security messages from lets encrypt . Cannot verify server identity with siteground132.sgcpanel.com. These pop up every few seconds and are making several of my devices unuseable. This probably relates to changing web site providers but so far neither is helping, just pointing at the other guy. Serial number is 03 8B 0D 59 E4 C5 8B FF BA D6 54 12 A5 DE DC 24 9F 9F

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

1 Like

Hi @plecostomus

that's not a public visible subdomain, that subdomain doesn't have a public ip address.

So it's something in the network of your hoster -> so ask your hoster.

How do I find my domain name? I am a real newbie

What kind of messages? Let's Encrypt doesn't message that often, most of the time only a few emails. I'm guessing these are browser errors? And not actually from Let's Encrypt?

Also, what are you actually doing when you get such a message?

Also, the certificate seems to be for siteground132.com if you look up the serial number and not for siteground132.sgcpanel.com. If you're seeing the certificate with that serial number belonging to siteground132.com when you're trying to go to siteground132.sgcpanel.com, the error is to be expected.

1 Like

How about we start with these questions:

  1. What are you trying to do?
  2. What is it that you're seeing instead? (Screenshots and/or copy/pasting whatever it is that you're not expecting would be best.)
  3. Are you the owner/maintainer of a web site that's involved here? Or are you just trying to use someone else's web site? (Or is this not related to web sites at all?)
2 Likes

Thanks for getting back. This just happens spontaneously on ipad and iphone. Keeps popping up every few seconds. Only when a browser is open. Changed web site provider some months ago but this just started happening in the last few weeks. Suspect a subscription ran out maybe related to the old web site provider. What software would be trying to go to sgcpanel.com? Seems I need to get rid of it

What does this mean? I mean, most of the time, people would know the domain name of the website they are hosting at a hosting provider.

Or did you mean internet service provider by any chance?

We run a small business and have a web site. Changed web site provider. We don't handle the tech side of it just content. Only thing I can think of that might be involved but could also be wrong.
All I can give you is our web address sewinspired.ca

The site has bugs, see the console - Crtl + Shift + I.

Uncaught ReferenceError: TrackJS is not defined
    <anonymous> https://www.sewinspired.ca/:22

May be that works on your local system and you have that error.

Or it's a problem not from the main page /, instead from another page of that domain -> then check / share that page.

Not sure why a bug on the website would make a remote iphone or ipad throw up the error.

Your site isn't using Let's Encrypt certificates for quite a while now:

Also, when I surf to your site, I see the Amazon certificate.
So, this isn't a Let's Encrypt issue, at least not for this site.

If I can try to summarize what I think you're saying:

  1. You own sewinspired.ca and (use some system somewhere to) update content on it, but don't actually work on the development/infrastructure side of it.
  2. When you visit the site, using an iPhone or iPad, you see an error that it can't connect to siteground132.sgcpanel.com. You don't know anything about what that name is, but you recently changed hosting companies.

So, my questions are:

  1. Is that all correct?
  2. You see the problem on an iPhone and an iPad? That is, is it two devices total that have seen the problem? Do you see any problems on any other types of devices (Android, Windows, Mac, etc.), or on any iPhone or iPad that hasn't used the site before the change?
  3. When do you see the problem? That is, is it just when you try to visit the home page in the iPhone or iPad's web browser, or do you need to click some links first?

Even if you answer all those, though, it's highly unlikely that anybody here will be able to help you. I know it's a bit confusing that you see "Let's Encrypt" in the error message, but what's actually going on is probably some server at sgcpanel.com isn't set up right to allow for connections to work, perhaps because you no longer use their services, and yet your devices are trying to connect to it. [What "Let's Encrypt" does is provide services to allow your web browser to validate that the system it is trying to connect to in fact owns the domain name that's being used, but that's basically it. It's not involved with setting up the domain name or web server beyond that.]

If it's a problem on your web site, somebody who is on the technical side of things for your domain is going to need to find out what is referencing that name and stop it from happening. If it's just a problem on your devices, somebody is going to need to figure out what on it is trying to connect to that name. In either event, there's probably not a lot we can do for you (as even if someone here did know what to fix you'd need the technical side to implement that fix), but there's a helpful bunch here so there is a chance we might be able to give you some direction. It's hard for us to understand exactly what you're seeing, though, since we aren't seeing the same problem (though I don't personally have an iDevice to test it on).

1 Like

Thanks Peter. The error message is only on two devices as far as I can tell. We only see the message when mail is activated. It happens without accessing the web site, just turn on the mail and its there. Suggests its tied to email somehow?

My wild guess, then, is that this doesn't have anything to do with your web site, but that when you changed hosting providers you also changed email providers, and you need to update the email configuration on the device to the new provider. But again, you probably need somebody on the technical side to things to tell you what email servers should be configured where.

1 Like

Yes. Why would it be tied to something else if it occurs when you turn on email?

I think you are right. email used to be through the old web site but now is ZOHO. Weird thing is its running in the background. Once it get started only a power cycle will stop it. I will try reentering the email connections and see what happens and will let you all know. Thanks for helping!

If you could share the public email information used, maybe we could help verify it.
[don't share any username nor passwords (or such)]

If it happens that often it has to be email service related.

Problem solved.

The emails were not accounts in settings but were still in the mail app on both the phone and Ipad.
Deleted and solved the problem.

Thanks to all that helped with this

2 Likes

2 posts were split to a new topic: Error issuing certificate

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.