New to Let's Encrypt. Creating new certificate. Error "Timeout during connect (likely firewall problem)"

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:
certbot certonly --nginx --dry-run -d -n --agree-tos

It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Simulating a certificate request for

Certbot failed to authenticate some domains (authenticator: nginx). The Certificate Authority reported these problems:
Type: connection
Detail: Fetching Timeout during connect (likely firewall problem)

Hint: The Certificate Authority failed to verify the temporary nginx configuration changes made by Certbot. Ensure the listed domains point to this nginx server and that it is accessible from the internet.

Some challenges have failed.
Ask for help or search for solutions at See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.

My web server is (include version):
nginx version: nginx/1.14.1

The operating system my web server runs on is (include version):
CentOS Linux release 8.5.2111

My hosting provider, if applicable, is:
None. Note that this is a domain owned by my ISP. It was given along with my home internet subscription. I don't own this domain.

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):
certbot 1.20.0

Tried searching different topics on the same issues but it didn't help. Verified that my provider is not blocking port 80 and 443. My web server host firewall is not running. There's more debug log in the attached log. Based on that log, if I'm not mistaken, my connection to letsencrypt server is fine.

Where should my .well-known/acme-challenge/ absolute path be?

letsencrypt.log.txt (29.1 KB)

1 Like

When using the nginx plugin, that shouldn't be something to worry about. Also, this isn't the problem: port 80 isn't reachable at all, not for your entire website.

Please first make your website accessible to the world wide web on port 80 and then try again.

Suggestion: is there a NAT router between your server and the www? If so, did you add the required portmaps there?


nmap to my address says that my port 80 is open. Port forwarding is configured in the router mapping internal 80 -> external 80. Accessing my website internal works great but inaccessible to the world wide web somehow.

curl -L -v
* Rebuilt URL to:
* Failed to connect to port 80: Connection timed out
* Closing connection 0
1 Like

Is the IP address correct?


Yes. It is. I'm at a lost why it can't establish the connection. Any other ideas? Appreciate your help so far.

1 Like

Currently I'm getting a no route to host as error when connecting to port 80.

Is the portmap set to the correct internal IP address?


Do you mean?:
mapping external 80 -> internal 80

Have you verified the internal IP hasn't changed?


Yes you're right about that and the IP hasn't changed.

1 Like

The connection to port 80 is problem #1 but note that domain is right now subject to Rate Limits. See


Hmm I don't get why port 80 is the problem.. When I ran letsdebug, I can see that the traffic is actually coming in to the port of the server.

So the problem can also be the rate limit? I should try again when it's unblocked again.

1 Like

That's a new, but different issue. Waiting until the rate limit is gone doesn't help your other issues.


Can you see it going back out :slight_smile:


No. It seems that everything that I do to reach my web host has got blackholed by the private interface. That's the problem. My host is a Virtualbox VM. The private interface is a bridged interface to the home network so that it can reach the internet. I never got anything back whether it's SSH or HTTP or HTTPS traffic. So, I've completely abandoned Virtualbox. I moved my web host to a different hypervisor and it's working like a charm. My HTTPS site is up and running!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.