My certificate is not trusted

Good day,

I may not be in the right place here but unfortunately I can't find the right solution anywhere.

On some computers and browsers, the certificate of my website is not trusted, so my website is not opened.

I've tried everything, I'm not a programmer, but I can't solve it.

My domain name is and I use the hosting services of Cloud86. My control panel is Plesk.

Thank you in advance and I hope someone can help me.

1 Like

Can you show an example error from one of those failing systems?

Because your cert looks fine to me


Such as which ones?

Have you cleared the browser cache on those browsers and exited the browser and restarted the browser?
Have you tried rebooting the computers?

1 Like

How old are those failing devices?
What O/S version are they using?

This sounds like the failing devices don't trust the "short LE chain".


User may have no control of which chain is used - likely on "shared hosting".


I wish all clients did the Path Building vs Path Verifying the way indicated here Verifying a certificate - #5 by jsha
To me it seems clients (web browsers, openssl, etc.) are to some extent broken. :frowning:

1 Like

Like this one

1 Like

"Blocked categories" sounds like there is a firewall in use.


Thank you for your help! Could it be that setting or category has to be changed to be accepted by this firewall?

1 Like

Yes, that is likely.
It should be the firewall controlling the outbound connections to the Internet for that system that is blocking.

Two suggestions for the firewall admin:

  • the block notice should include the system names or IPs that is doing the block and being blocked
  • the block notice should include a contact name or number to request an exception to this block

I don't know which firewall system is being used...
But checking with Fortinet/Fortiguard, I do see:

It might just be that the site is too new.


Thank you very much for your help! Is there anything I can do to change this?


But it depends on knowing what system was doing the blocking and mainly where it got the information.

I also have two recommendations for your host [if you get a chance to speak with them]:

  • enable TLS v1.3
  • enable IPv6

Thank you very much for your help, I appreciate it! I will contact my hosting provider.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.