Multiple issues with renewal

I’m trying to renew my certificate. I started with the simple certbot renewal. It noted an error binding to port 80 so I tried adding the hooks to stop and start apache. Neither of these worked. I’ve currently hit the rate limit so I’m trying --dry-run for now but I get a new error below:

My domain is:

I ran this command: sudo certbot renew

It produced this output:

Attempting to renew cert ( from /etc/letsencrypt/renewal/ produced an unexpected error: urn:ietf:params:acme:error:malformed :: The request message was malformed :: Method not allowed. Skipping.
All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/ (failure)

My web server is (include version): Apache2

The operating system my web server runs on is (include version): Ubuntu 18.04

My hosting provider, if applicable, is: DigitalOcean

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): 0.31

1 Like


Please update your certbot before continue request certificate.

sudo apt update && sudo apt upgrade

Thank you

1 Like

Ok, I ran an update but not upgrade. After running that, then renewing with the start and stop hooks, followed by restarting apache, it worked! Thanks so much for your help.


Glad it worked.

The version you on is released around Feb 2019 and Let’s Encrypt undergo some changes…and the latest certbot version is 1.0.0… (it’s always great to check updates :slight_smile:)


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.