Cant renew on ubuntu 16.04 apache LAMP server


#1

Hey all

Trying to renew my cert and it keeps failing, have searched high and low, I think that I might not have the apache plugin installed.

I have tried reinstalling letsencrypt

apt-get install python-letsencrypt-apache

When I type in “letsencrypt” the blue interface shows up with my certs listed, but when I type in “letsencrypt renew” I have an Error: server

Can’t seem to get the auto renew to work either.

Can anyone assist me?

Thanks


#2

Hi @Heetered, can you please post the exact error message that you’re getting?


#3

Hi, Thanks for your response,

Here Ya go:

root@SERV:/home/adminpc# letsencrypt --apache renew
Processing /etc/letsencrypt/renewal/example.com.conf
2017-02-08 21:15:53,425:WARNING:letsencrypt.cli:Attempting to renew cert from /etc/letsencrypt/renewal/example.com.conf produced an unexpected error: 'server'. Skipping.

All renewal attempts failed. The following certs could not be renewed:
  /etc/letsencrypt/live/example.com/fullchain.pem (failure)
1 renew failure(s), 0 parse failure(s)
root@SERV:/home/adminpc# 

#4

This problem usually happens when initially installing Certbot or letsencrypt from git or letsencrypt-auto, and then “upgrading” to an Ubuntu OS package. Is that perhaps what you did in this case?

The trouble is that the Ubuntu package is actually an older version of the client, and the renewal configuration files aren’t backwards-compatible, so ideally you should use the later version you have installed ( possibly certbot ? )


#5

Great, thanks for the response

I will reinstall the git clone version way. Then. Is there a proper clean way to uninstall?

Regards


#6

Hey all,

So I have tried just installing the git and git clone and I still am getting same error. Definitely looks like I have to uninstall everything and reinstall.
I am looking around and searching how to uninstall, and there is many different versions, all with issues.

Can someone direct me to the proper way of uninstalling all of this letsencrypt?

Regards


#7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.