Move a website from webinoly to a new server that has installed virtualmin

i need to move a website from webinoly to a new server that has installed virtualmin
the domain already has ssl with lets encrypt and both servers have nginx

i created the domain with ssl in the new server but when i tried to get a new certificate i had this message that i write at the end

since i can not issue a new ssl i believe that i have to copy the old one

but the problem is that i have no idea what to copy from where to which directory or file in my new server

My domain is:mamadisio.gr

the error message is:

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator webroot, Installer None
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for mamadidio.gr
Using the webroot path /home/mymamadisiogr/public_html for all unmatched domains.
Waiting for verification...
Challenge failed for domain mamadidio.gr
http-01 challenge for mamadidio.gr
Cleaning up challenges
Some challenges have failed.
IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: mamadidio.gr
    Type: dns
    Detail: DNS problem: NXDOMAIN looking up A for mamadidio.gr - check
    that a DNS record exists for this domain

2 Likes

Sorry to hear about this trouble.

It may be related to a problem with the .gr TLD.
See: https://dnsviz.net/d/mamadisio.gr/dnssec/

OR

It might be related to the non-responsive HTTP via the IPv6 address listed for your domain:

Name:       mamadisio.gr
Addresses:  2a01:7e01::f03c:92ff:fedc:e5ed
            172.104.205.240

See: https://letsdebug.net/mamadisio.gr/365662

2 Likes

i believe i was not clear.
My domain mamadisio.gr has an ssl with ip 139.162.168.101 that i had automatically obtain whith webinily

now i moved the domain at another server with another ip that virtualmin is installed, but i couldn't get another ssl with letsencrypt, obviously because it still has the old certificate in the old server

What should i do to move the ssl to the new server ?

can i delete the first ssl certificate and create a new one for the same domain? or i have to copy some files with the certificate to the new server from the old one?

1 Like

Hi @panzam

no, that's completely unrelevant.

It's only a problem of your new server.

Create a new certificate in your new environment, that's all.

But to do that, you have to change your dns entry domain -> ip.

Now, your domain doesn't have an ip address, that's your error message. Change that.

1 Like

my domain mamadisio.gr has the correct dns in cloudflare
if you ping it, it is
Pinging mamadisio.gr [172.104.205.240] with 32 bytes of data:
Reply from 172.104.205.240: bytes=32 time=68ms TTL=53
Reply from 172.104.205.240: bytes=32 time=67ms TTL=53
Reply from 172.104.205.240: bytes=32 time=69ms TTL=53
Reply from 172.104.205.240: bytes=32 time=70ms TTL=53
the correct ip of the new server

1 Like

Your topic has two different domains.

That domain doesn't have an ip address.

Checking mamadisio.gr - your configuration is buggy - see https://check-your-website.server-daten.de/?q=mamadisio.gr

You have ipv4 and ipv6 - but your ipv6 doesn't work. That's fatal because Letsencrypt prefers ipv6 checking your domain name.

Ipv4 + http answers, ipv6 + http doesn't answer -> certificate creation via http validation will fail.

  • Fix your ipv6 (or, not so good)
  • Remove the ipv6 AAAA record
3 Likes

i deleted aaa dns and worked perfect
thank you!!!

3 Likes