Missing suffix .com

I've just tried running this for the first time after setting up a VM on Azure.
Something strange has happened. I can access the website just fine, however when I run the command, the domain that it comes up with is missing the suffix .com and therefore is not accepted. Any idea why?

My domain is:

I ran this command:
sudo certbot --apache

It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log

Which names would you like to activate HTTPS for?

1: www.charezza

Select the appropriate numbers separated by commas and/or spaces, or leave input
blank to select all options shown (Enter 'c' to cancel): 1
Requesting a certificate for www.charezza
An unexpected error occurred:
The server will not issue certificates for the identifier :: Error creating new order :: Cannot issue for "www.charezza": Domain name does not end with a valid public suffix (TLD)
Ask for help or search for solutions at https://community.letsencrypt.org. See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.

The operating system my web server runs on is (include version):
Ubuntu 20.04.2 LTS

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):
I'm using a control panel to manage my site (no, or provide the name and version of the control panel):
The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):
certbot 1.16.0

1 Like

It looks like your Apache is misconfigured. Please check if your hostname is correct in the Apache configuration and if not: correct it and run sudo certbot --apache again.


Welcome to the Let's Encrypt Community :slightly_smiling_face:

A great place to start the investigation that @Osiris has suggested is by running:

sudo apachectl -S

That should indicate in which apache configuration file there is an incomplete ServerName or ServerAlias.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.