Error Running Certbot


#1

Hello,

I get the following error when trying to run ./certbot-auto --apache
An unexpected error occurred: The request message was malformed :: Error creating new order :: Name does not end in a public suffix

I set the path using following in second attempt ./certbot-auto --apache --apache-challenge-location /etc/apache2

I get the same error when activating all domains and subdomains


#2

Hi @Uneschewed

what’s your domain name? Your domain name must end with a public suffix like .com, .de, .eu, .travel etc.

https://publicsuffix.org/

If not, you can’t get a public certificate.


#3

Where does it pull the name from, I have an external address


#4

When you use --apache the names are pulled from your Apache configuration.

You can override this by specifying one or more names explicitly with the -d option.


#5

When I run this command ignoring the extension which ends in .localhost, I select all others which end in .com

and I get this message on them

Failed authorization procedure. .com (http-01): urn:ietf:params:acme:error:dns :: DNS problem: NXDOMAIN looking up A for


#6

Then one domain has a wrong or missing dns entry.


#7

Hello,

I have again installed certbot and now face an error which says

The apache plugin is not working; there may be problems with your existing configuration.
The error was: NoInstallationError(‘Could not find configuration root’,)

I try to run the command ./certbot-auto --apache --apache-challenge-location /etc/apache2


#8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.