LetsEncrypt NXDOMAIN but I can resolve it fine

My domain is: sbtest.safebanker.com

I ran this command: certbot certonly -d sbtest.safebanker.com --webroot -w /var/www/html/letsencrypt

It produced this output:

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator webroot, Installer None
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for sbtest.safebanker.com
Using the webroot path /var/www/html/letsencrypt for all unmatched domains.
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. sbtest.safebanker.com (http-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: DNS problem: NXDOMAIN looking up A for sbtest.safebanker.com

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: sbtest.safebanker.com
    Type: connection
    Detail: DNS problem: NXDOMAIN looking up A for
    sbtest.safebanker.com

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

My web server is (include version): Nginx v1.13.8

The operating system my web server runs on is (include version): Ubuntu 16.04.3

My hosting provider, if applicable, is: n/a

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no


I am trying to issue a certificate for a new sudomain. I put the subdomain in as a CNAME in my Godaddy DNS, as I have done for many other subdomains in the past.

When I run the certbot command listed above, I get the error that LetsEncrypt got an NXDOMAIN result for the subdomain.

I have tested from multiple locations (my computer and several servers) and dig sbtest.safebanker.com returns the correct result on all of them. Only LE is getting NXDOMAIN.

What can I do to get a certificate using Certbot?

Turns out to be a typo in the DNS record.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.