Lets Encrypt on Windows and IIS8

I am having some real issues with a renewed SSL Cert not being picked up by IIS8
I use Plesk Onyx and Lets Encrypt (comes with it)

The domain name has it’s own IP Address, and the cert was working this morning.
Now when I go to the URL it shows the SSL for the certificate that is on the default website.

I have tried everything for about 2 hours including rebooting the server

My domain is: orders.mmow.com.au

My web server is (include version): IIS8

The operating system my web server runs on is (include version): Windows 2012 RS

1 Like

Hi @inhale

that problem isn’t visible. Not with my browser, not via https://check-your-website.server-daten.de/?q=orders.mmow.com.au

There is a login with the correct certificate.

CN=orders.mmow.com.au
	05.08.2020
	03.11.2020
expires in 90 days	orders.mmow.com.au - 1 entry

There are some problems, mixed content, a Google font.

http://fonts.googleapis.com/css?family=Open+Sans:400,300,600,700&subset=all

And a Grade X, some name server problems you should fix.

But no certificate problems.

May be an old cache.

2 Likes

Thanks Juergen for the prompt response.
I had worked out a solution just before you checked.

For others… who haven’t been through the excruciating process of elmination.

When you create an SSL cert through Plesk, it occasionally adds 1 blank binding to the site with the IP Address. This is usually the HTTP version on port 80.

There are 2 solutions

  1. You add the HTTPS version of the blank binding for that IP Address
    This works but if you have 2 domains on the same IP Address then the other will stop working

  2. Delete this blank binding IP Address altogether
    That allowed all domains on the IP Address to work

As another safeguard … I bind the domain to the IP Address for all

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.