Lets encrypt certification on purchased domain in new server

My domain is:
godspotlight.org

I ran this command:
In directadmin I requested a new let’sencrypt certificate

My hosting provider, if applicable, is:
vimexx

I can login to a root shell on my machine (yes or no, or I don’t know):
I do not have full root access, but can do/see a lot

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
yes, directadmin

So I recently registered a domain that had expired from its previous owner (it was out of use for somewhat less than a year). I tried creating new SSL certficates, but failed with unkown error. I’m still trying to find the error logs for this, but can’t so far. Then I had a thought: It still had certificates on them valid till 2020-10-09 as far as I can see ( https://crt.sh/?q=godspotlight.org ). Of course from the previous owner. Can this be the cause of the problem? I have no means of accessing that old server as I was not the owner (and I don’t think its online anymore anyways). What can I do?

Regards

1 Like

No - they wouldn’t be a problem.

To me, it looks like godspotlight.org still points at a Vimexx domain parking page.

You need to setup its DNS so that it points to your DirectAdmin server.

Until then, you won’t be able to issue a certificate via DirectAdmin.

3 Likes

Ok that sounds like a valid source of the problem. I know I changed dns pointers but maybe it’s still being processed.

Thanks for your quick reply and investigation.

1 Like

It seems the whole DNS trace still goes through the Vimmex nameservers. From whom did you buy the domain?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.