K8s Too many failed authorizations recently

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: nmis-digf-sarif-a.nms.strath.ac.uk

I ran this command: sudo certbot certonly --standalone --preferred-challenges http -d nmis-digf-sarif-a.nms.strath.ac.uk

It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator standalone, Installer None
Obtaining a new certificate
An unexpected error occurred:
There were too many requests of a given type :: Error creating new order :: too many failed authorizations recently: see https://letsencrypt.org/docs/failed-
Please see the logfiles in /var/log/letsencrypt for more details.

My web server is (include version): kubernetes ingress controller

The operating system my web server runs on is (include version): ubuntu 20.04
kuberctl version --short
Client Version: v1.25.2
Kustomize Version: v4.5.7
Server Version: v1.25.2

My hosting provider, if applicable, is: N/A

I can login to a root shell on my machine (yes or no, or I don't know): Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):
certbot 0.40.0

Hi @jeffenhuang, and welcome to the LE community forum :slight_smile:

Please use the staging environment for all testing.
Once testing has been completed successfully, then you may switch back to the production LE system.


Thanks,r, may I know where is the staging environment? I am new to this.

1 Like

Add --dry-run to your certbot command.

More information:


hi, Peter, Thanks, I run it with --dry-run but got 404 error. is this because the kubernetes port mapping issue?

sudo certbot certonly --standalone --preferred-challenges http -d nmis-digf-sarif-a.nms.strath.ac.uk --dry-run
[sudo] password for jhuang:
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator standalone, Installer None
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for nmis-digf-sarif-a.nms.strath.ac.uk
Waiting for verification...
Challenge failed for domain nmis-digf-sarif-a.nms.strath.ac.uk
http-01 challenge for nmis-digf-sarif-a.nms.strath.ac.uk
Cleaning up challenges
Some challenges have failed.


  • The following errors were reported by the server:

    Domain: nmis-digf-sarif-a.nms.strath.ac.uk
    Type: unauthorized
    Detail: Invalid response from

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address.

  • Your account credentials have been saved in your Certbot
    configuration directory at /etc/letsencrypt. You should make a
    secure backup of this folder now. This configuration directory will
    also contain certificates and private keys obtained by Certbot so
    making regular backups of this folder is ideal.

1 Like

You are using "--standalone".
This implies there is no running web service.
But we can see something listening on HTTP port 80:

curl -Ii http://nmis-digf-sarif-a.nms.strath.ac.uk/
HTTP/1.1 404 Not Found
Date: Tue, 01 Aug 2023 17:35:41 GMT
Content-Type: text/html
Content-Length: 146
Connection: keep-alive

So, there is either some proxy/device in front of your web server OR we are not connecting to the right IP.
If there is a "proxy", it must be configured to proxy the ACME challenge requests to your server.
If that is NOT the correct IP, you need to update the DNS zone accordingly.


There are the following ingress services running.

nginx-ingress-ingress-nginx-controller LoadBalancer 80:31517/TCP,443:30935/TCP 12d
nginx-ingress-ingress-nginx-controller-admission ClusterIP 443/TCP

Not sure if I need run the certbot --nginx or not?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.