Invalid response while creating certificate

Hi all,

im a beginner with webservers - just rented a VPS to about configuration and security.
Private im using a Linux Mint 17 system - so I own a litte knowledge about console and basic principles.

My domain is:

My operating system on my webserver is Ubuntu-20.4
My control panel is Plesk Obsidian 18.0.45
My HostingProvider is 1Blue

its VPS-Server
PHP8.0.21 enabled

I can LogIn via ShellConsole

Its a plain new install - no additional software (except letsencrypt) added.
0. The website is bound to the IP.

  1. I tried to receive a SSL-Certificate through the plesk guide
    1.1. logged into the 1blue environment - ->DNS
    1.2. added a new record type "text" with host
    1.3. added the key provided by plesk
    1.4. save and exit

waiting for 24hrs.

  1. Check mxtools for DNS for
    2.1. no DNS record
    2.2. go back to plesk
    2.3. press the "reload button" to get a certificate

failure ... the challenge failed.

Did a complete re-install of the Ubuntu-system to a plain system once again.

Tried to follow step by step this:

It ends up with a "invalid response from

To fix these errors, please make sure that your domain name was entered correctly and the DNS A/AAAA records for that domain contain the the right IP adress.

Lets Debug say: its ok say: DNS record is ok, not secured say: DNS record ok, its bound to the correct IP I see in Plesk as in 1blue environment too.

result of certbot --version: 0.40.0

Within the plesk control panel
hostsettings for i can´t disable http=>https forwarding

2022-08-07 4:20PM

say in section 3:


  1. Content- and Performance-critical Checks 502 Fatal: Check of /.well-known/acme-challenge/random-filename has a http status 500 - 599, Server Error. Creating a Letsencrypt certificate via http-01 challenge can't work. Trouble creating a certificate? Use to ask.

What can I do ?

1 Like

I don't know Plesk well but that should work. You must have made an error entering the info for the TXT record. Can you add the TXT record again and let us know? We can look at it and maybe see something you don't.

You can enter any value for now. No need to even start the cert request - just add the DNS record. Thanks

PS: I don't see a 502 error. I do see that https requests return a self-signed default Plesk cert. But, that's expected until you get a new cert.


I used a text it was already used in the past attempt.
I need to enter the TXT-parameters at the providers environment - not in Plesk.

1 Like

I see the problem. The name in the left column should just be _acme-challenge similar to how you have just www and just mail

You have a TXT record but under this wrong name: 86400 IN TXT "EGmMlpnIEQ-Uhk2YM0oiZgf0lKYqXz1ThtHRC5QRUX0"

thanks for the moment - I´ll uninstall the certbot script and remove the directories and keys which where created through the process described in the

"Tried to follow"

section of my initial posting.

Will run the plesk procedure once again, when done.

1 Like

That shouldn't be necessary.


Its actual in progress now.

Just to avoid conflicts ...
I like the plesk panel a little bit, but do not trust completly :slight_smile:


Thanks a lot for your hint ... its done now.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.