Could not issue an SSL/TLS certificate (Error: 403)

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: jeetpharma.com

I ran this command: Tried issuing Let's Encrypt SSL via Plesk (added the DNS record corrrectly too).

It produced this output:

My web server is (include version): Apache 2.4.29

The operating system my web server runs on is (include version): Ubuntu 18.04.5 LTS

My hosting provider, if applicable, is: 1&1 / ionos.ca

I can login to a root shell on my machine (yes or no, or I don't know): Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): Plesk Obsidian 18.0.30

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 0.27.0 (Literally installed it for the purpose of answering this question)

Extra Notes: The domain was registered at ipage.com. Only putting this info because I have 8 domains from different registrars and this issue has never come up for any of the other 7 domains.

Any help will be appreciated. Thanks in advance!

2 Likes

Welcome to the Let's Encrypt Community, Ahil :slightly_smiling_face:

Given your experience, it looks like the previous challenge (that used the TXT record(s) you have created) may have failed, resulting in new TXT records being issued (that have been overlooked). I see this most often when not enough time has been allowed for the TXT records to propagate before trying to confirm the completion of the challenge(s).

Try again, being sure you have added the current TXT record(s). Before confirming the challenge(s), you can verify their existence using the following tool by entering the full challenge host (e.g. _acme-challenge.jeetpharma.com) in the box and clicking TXT:

2 Likes

Hey Griffin,

Thanks for your help. Guess I was just being impatient haha.

2 Likes