Installing SSL on a Sub Domain - Plesk 12.5


#1

Hi,

We are trying to install an SSL on a sub domain but we are getting the following error…

Error: Let’s Encrypt SSL certificate installation failed: Failed letsencrypt execution: Saving debug log to /usr/local/psa/var/modules/letsencrypt/logs/letsencrypt.log
Starting new HTTPS connection (1): acme-v01.api.letsencrypt.org
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for cloud2.istech.ie
Starting new HTTPS connection (1): 127.0.0.1
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. cloud2.istech.ie (http-01): urn:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from http://cloud2.istech.ie/.well-known/acme-challenge/_TGr0r2W0y33zrXzopvoh1ZL9YiuL4acYv6Q-1CilqI: "<!DOCTYPE html>
<!–[if lte IE 9 ]><html class=“ie lt-ie9” lang=“en-GB” prefix=“og: http://ogp.me/ns#”> <![endif]–>
<!–[if (gt"
IMPORTANT NOTES:

  • The following errors were reported by the server:

Domain: cloud2.istech.ie
Type: unauthorized
Detail: Invalid response from
http://cloud2.istech.ie/.well-known/acme-challenge/_TGr0r2W0y33zrXzopvoh1ZL9YiuL4acYv6Q-1CilqI:
"<!DOCTYPE html>
<!–[if lte IE 9 ]><html class="ie lt-ie9" lang="en-GB" prefix="og:
http://ogp.me/ns#"> <![endif]–>
<!–[if (gt"

To fix these errors, please make sure that your domain name was
entered correctly and the DNS A record(s) for that domain
contain(s) the right IP address.

We have checked to confirm that DNS A record points to the right IP Address.

We’re very new to Let’s Encrypt so any help would be much appreciated.

Thanks

Eoin


#2

What is your domain setup / configuration ?

If I try going to the verification link ( http://cloud2.istech.ie/.well-known/acme-challenge/_TGr0r2W0y33zrXzopvoh1ZL9YiuL4acYv6Q-1CilqI ) then I get a redirect to http://www.dunnesfarmstore.ie/ which doesn’t, of course, contain the value of the token expected.


#3

Thanks for getting back to us.

We fixed that problem with the redirect but we are now getting the following error…

Not Found

The requested URL /.well-known/acme-challenge/_TGr0r2W0y33zrXzopvoh1ZL9YiuL4acYv6Q-1CilqI was not found on this server.

Thanks

Eoin


#4

If you create a simple text test file at “webroot”/.well-known/acme-challenge/test where"webroot" is the top level of files where your website is - usually your index.php can you reach it via http://cloud2.istech.ie/.well-known/acme-challenge/test ?


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.