Error unauthorized - Failed authorization procedure


#1

Hello,

I run Ubuntu 14.

On 13.3.2017 I installed letsencrypt via SSH. During this time my provider had some DNS Problems. It was not possible to create the certificate because of DNS A Problems. One day later this DNS Problems are gone but my host told me, that there is a letsencrypt extension in Plesk 12.5. I was running Plesk 11.
Last night my host updated sucessfull my Plesk 11 to Plesk 12.5.

I installed the letsencrypt extension for Plesk 12.5 and tried to create the certificate but I get always this error message:


Starting new HTTPS connection (1): acme-v01.api.letsencrypt.org
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for mydomain.de
Starting new HTTPS connection (1): 127.0.0.1
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. mydomain.de (http-01): urn:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from http://mydomain.de/.well-known/acme-challenge/sYj-C84PkAIVPVhKdPadvwijfXxqOE08nyDgwfAuhO4: "<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html"
IMPORTANT NOTES:

  • The following errors were reported by the server:

Domain: mydomain.de
Type: unauthorized
Detail: Invalid response from
http://mydomain.de/.well-known/acme-challenge/sYj-C84PkAIVPVhKdPadvwijfXxqOE08nyDgwfAuhO4:
"<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html"

To fix these errors, please make sure that your domain name was
entered correctly and the DNS A record(s) for that domain
contain(s) the right IP address.

What I did to fix this:

  1. When I try a subdomain (cdn.mydomain.de) everything works well.
  2. There is NO DNS Problem anymore.I check this many times
  3. When I create the Folders .well-known/acme-challenge/test.html under my domain root I can access this file. So no .htaccess Problem

I think it has something to do with my letsencrypt installation before via ssh and maybe the DNS Problems during this time. Maybe in any file are a wrong configuration for the domain? Or the path to .well-known/acme-challenge is wrong, because its a vhost now in Plesk?

  1. I delete the letsencrypt folders in /opt/letsencrypt and /etc/letsencrypt/

Thank you very much for help. I appreciate it!

Kind regards


#2

i believe the issue you are facing is that you are returning HTML instead of application/text files

can you let us know what your domain is so we can verify and assist

without a domain name we are not bale to assist

Andrei


#3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.