Installing SSL certificate


#1

Hi I got this error,
Let’s Encrypt SSL certificate installation failed: Failed letsencrypt execution: Traceback (most recent call last):

I ran the Python update which I think worked, but the upgrade cryptography command failed as follow:

Rolling back uninstall of cryptography
Command “/usr/local/psa/var/modules/letsencrypt/venv.D7NCJ/bin/python -u -c “import setuptools, tokenize;file=’/tmp/pip-build-9_dXu6/cryptography/setup.py’;f=getattr(tokenize, ‘open’, open)(file);code=f.read().replace(’\r\n’, ‘\n’);f.close();exec(compile(code, file, ‘exec’))” install --record /tmp/pip-6YvQVq-record/install-record.txt --single-version-externally-managed --compile --install-headers /usr/local/psa/var/modules/letsencrypt/venv.D7NCJ/include/site/python2.7/cryptography” failed with error code 1 in /tmp/pip-build-9_dXu6/cryptography/


#2

Can you provide a little more information please.

What command were you running ?

What is your operating system ?

What client are you using (I’m assuming certbot) and version ?

If certbot, how did you install it ?


#3

Hi

I have installed the extention in Plesk Onyx.

I ran these commands using PuTTY (Release 0.67) as root:

For Red-Hat:

Update python:

yum install gcc libffi-devel python-devel openssl-devel dialog

Upgrade cryptography module:

cd /usr/local/psa/var/modules/letsencrypt/venv/bin

./pip install --upgrade cryptography


#4

Interesting - are all other packages up-to-date (yum update ) ?


#5

My plesk was just upgraded to what I’m told is the latest stable version.

How do I do a yum update
?


#6

You can run “yum update” via SSH (PuTTY). It’s the command to update the packages on your main operating system you may want to just run “yum check-update” first - to see what it says needs updating. See https://access.redhat.com/solutions/9934


#7

Here is the result of the check:

Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile

alsa-lib.x86_64 1.1.0-4.el6 base
audit-libs.x86_64 2.4.5-3.el6 base
authconfig.x86_64 6.1.12-23.el6 base
avahi-libs.x86_64 0.6.25-15.el6_8.1 updates
bash.x86_64 4.1.2-40.el6 base
bash-completion.noarch 1:1.3-7.el6 epel
bind.x86_64 32:9.8.2-0.47.rc1.el6_8.3 updates
bind-libs.x86_64 32:9.8.2-0.47.rc1.el6_8.3 updates
bind-utils.x86_64 32:9.8.2-0.47.rc1.el6_8.3 updates
binutils.x86_64 2.20.51.0.2-5.44.el6 base
boost-date-time.x86_64 1.41.0-28.el6 base
boost-filesystem.x86_64 1.41.0-28.el6 base
boost-program-options.x86_64 1.41.0-28.el6 base
boost-regex.x86_64 1.41.0-28.el6 base
boost-serialization.x86_64 1.41.0-28.el6 base
boost-system.x86_64 1.41.0-28.el6 base
boost-thread.x86_64 1.41.0-28.el6 base
ca-certificates.noarch 2015.2.6-65.0.1.el6_7 base
cairo.x86_64 1.8.8-6.el6_6 base
centos-indexhtml.noarch 6-2.el6.centos base
centos-release.x86_64 6-8.el6.centos.12.3 base
chkconfig.x86_64 1.3.49.5-1.el6 base
coreutils.x86_64 8.4-43.el6 base
coreutils-libs.x86_64 8.4-43.el6 base
cpio.x86_64 2.10-12.el6_5 base
cronie.x86_64 1.4.4-16.el6_8.2 updates
cronie-noanacron.x86_64 1.4.4-16.el6_8.2 updates
cscope.x86_64 15.6-7.el6 base
cups-libs.x86_64 1:1.4.2-74.el6 base
curl.x86_64 7.19.7-52.el6 base
cyrus-sasl.x86_64 2.1.23-15.el6_6.2 base
cyrus-sasl-lib.x86_64 2.1.23-15.el6_6.2 base
cyrus-sasl-md5.x86_64 2.1.23-15.el6_6.2 base
cyrus-sasl-plain.x86_64 2.1.23-15.el6_6.2 base
db4.x86_64 4.7.25-20.el6_7 base
db4-cxx.x86_64 4.7.25-20.el6_7 base
db4-devel.x86_64 4.7.25-20.el6_7 base
db4-utils.x86_64 4.7.25-20.el6_7 base
dbus-libs.x86_64 1:1.2.24-8.el6_6 base
device-mapper.x86_64 1.02.117-7.el6_8.1 updates
device-mapper-libs.x86_64 1.02.117-7.el6_8.1 updates
dhclient.x86_64 12:4.1.1-51.P1.el6.centos base
dhcp-common.x86_64 12:4.1.1-51.P1.el6.centos base
docker-io.x86_64 1.7.1-2.el6 epel
dracut.noarch 004-409.el6_8.2 updates
dracut-kernel.noarch 004-409.el6_8.2 updates
e2fsprogs.x86_64 1.41.12-22.el6 base
e2fsprogs-libs.i686 1.41.12-22.el6 base
e2fsprogs-libs.x86_64 1.41.12-22.el6 base
elfutils.x86_64 0.164-2.el6 base
elfutils-libelf.x86_64 0.164-2.el6 base
elfutils-libs.x86_64 0.164-2.el6 base
elrepo-release.noarch 6-6.el6.elrepo elrepo
ethtool.x86_64 2:3.5-6.el6 base
expat.x86_64 2.0.1-13.el6_8 updates
file.x86_64 5.04-30.el6 base
file-libs.x86_64 5.04-30.el6 base
findutils.x86_64 1:4.4.2-9.el6 base
finger.x86_64 0.17-40.el6 base
finger-server.x86_64 0.17-40.el6 base
flex.x86_64 2.5.35-9.el6 base
fontconfig.x86_64 2.8.0-5.el6 base
fontconfig-devel.x86_64 2.8.0-5.el6 base
freetype.x86_64 2.3.11-17.el6 base
freetype-devel.x86_64 2.3.11-17.el6 base
gawk.x86_64 3.1.7-10.el6_7.3 base
gdb.x86_64 7.2-90.el6 base
gdbm.x86_64 1.8.0-39.el6 base
gdbm-devel.x86_64 1.8.0-39.el6 base
gettext.x86_64 0.17-18.el6 base
gettext-devel.x86_64 0.17-18.el6 base
gettext-libs.x86_64 0.17-18.el6 base
git.x86_64 1.7.1-4.el6_7.1 base
glib2.i686 2.28.8-5.el6 base
glib2.x86_64 2.28.8-5.el6 base
glibc.i686 2.12-1.192.el6 base
glibc.x86_64 2.12-1.192.el6 base
glibc-common.x86_64 2.12-1.192.el6 base
glibc-devel.x86_64 2.12-1.192.el6 base
glibc-headers.x86_64 2.12-1.192.el6 base
gmp.x86_64 4.3.1-10.el6 base
gnupg2.x86_64 2.0.14-8.el6 base
gnutls.x86_64 2.8.5-19.el6_7 base
grep.x86_64 2.20-5.el6_8 updates
grubby.x86_64 7.0.15-7.el6 base
gtk2.x86_64 2.24.23-8.el6 base
gzip.x86_64 1.3.12-22.el6 base
hwdata.noarch 0.233-16.1.el6 base
initscripts.x86_64 9.03.53-1.el6.centos.1 updates
iproute.x86_64 2.6.32-54.el6 base
iptables.x86_64 1.4.7-16.el6 base
iputils.x86_64 20071127-21.el6 base
jasper-libs.x86_64 1.900.1-16.el6_6.3 base
kernel.x86_64 2.6.32-642.11.1.el6 updates
kernel-devel.x86_64 2.6.32-642.11.1.el6 updates
kernel-firmware.noarch 2.6.32-642.11.1.el6 updates
kernel-headers.x86_64 2.6.32-642.11.1.el6 updates
keyutils-libs.i686 1.4-5.el6 base
keyutils-libs.x86_64 1.4-5.el6 base
keyutils-libs-devel.x86_64 1.4-5.el6 base
krb5-devel.x86_64 1.10.3-57.el6 base
krb5-libs.i686 1.10.3-57.el6 base
krb5-libs.x86_64 1.10.3-57.el6 base
less.x86_64 436-13.el6 base
libX11.x86_64 1.6.3-2.el6 base
libX11-common.noarch 1.6.3-2.el6 base
libX11-devel.x86_64 1.6.3-2.el6 base
libXcursor.x86_64 1.1.14-2.1.el6 base
libXext.x86_64 1.3.3-1.el6 base
libXfixes.x86_64 5.0.1-2.1.el6 base
libXft.x86_64 2.3.2-1.el6 base
libXft-devel.x86_64 2.3.2-1.el6 base
libXi.x86_64 1.7.4-1.el6 base
libXinerama.x86_64 1.1.3-2.1.el6 base
libXrandr.x86_64 1.4.2-1.el6 base
libXrender.x86_64 0.9.8-2.1.el6_8.1 updates
libXrender-devel.x86_64 0.9.8-2.1.el6_8.1 updates
libXtst.x86_64 1.2.2-2.1.el6 base
libarchive.x86_64 2.8.3-7.el6_8 updates
libblkid.x86_64 2.17.2-12.24.el6_8.1 updates
libcgroup.x86_64 0.40.rc1-18.el6_8 updates
libcom_err.i686 1.41.12-22.el6 base
libcom_err.x86_64 1.41.12-22.el6 base
libcom_err-devel.x86_64 1.41.12-22.el6 base
libcurl.x86_64 7.19.7-52.el6 base
libdrm.x86_64 2.4.65-2.el6 base
libgcj.x86_64 4.4.7-17.el6 base
libgcrypt.x86_64 1.4.5-12.el6_8 updates
libicu.x86_64 4.2.1-14.el6 base
libopendkim.x86_64 2.11.0-0.1.el6 epel
libpcap.x86_64 14:1.4.0-4.20130826git2dbcaa1.el6 base
libpcap-devel.x86_64 14:1.4.0-4.20130826git2dbcaa1.el6 base
libpciaccess.x86_64 0.13.4-1.el6 base
libpng.i686 2:1.2.49-2.el6_7 base
libpng.x86_64 2:1.2.49-2.el6_7 base
libproxy.x86_64 0.3.0-10.el6 base
libproxy-bin.x86_64 0.3.0-10.el6 base
libproxy-python.x86_64 0.3.0-10.el6 base
libselinux.i686 2.0.94-7.el6 base
libselinux.x86_64 2.0.94-7.el6 base
libselinux-devel.x86_64 2.0.94-7.el6 base
libselinux-utils.x86_64 2.0.94-7.el6 base
libsemanage.x86_64 2.0.43-5.1.el6 base
libss.x86_64 1.41.12-22.el6 base
libssh2.x86_64 1.4.2-2.el6_7.1 base
libtalloc.x86_64 2.1.5-1.el6_7 base
libtdb.x86_64 1.3.8-3.el6_8.2 updates
libtevent.x86_64 0.9.26-2.el6_7 base
libtiff.x86_64 3.9.4-18.el6_8 updates
libtirpc.x86_64 0.2.1-11.el6_8 updates
libudev.x86_64 147-2.73.el6_8.2 updates
libuser.x86_64 0.56.13-8.el6_7 base
libuuid.x86_64 2.17.2-12.24.el6_8.1 updates
libxcb.x86_64 1.11-2.el6 base
libxcb-devel.x86_64 1.11-2.el6 base
libxml2.i686 2.7.6-21.el6_8.1 updates
libxml2.x86_64 2.7.6-21.el6_8.1 updates
libxml2-python.x86_64 2.7.6-21.el6_8.1 updates
logrotate.x86_64 3.7.8-26.el6_7 base
lsof.x86_64 4.82-5.el6 base
lxc.x86_64 1.0.9-1.el6 epel
lxc-libs.x86_64 1.0.9-1.el6 epel
mailx.x86_64 12.4-8.el6_6 base
make.x86_64 1:3.81-23.el6 base
mlocate.x86_64 0.22.2-6.el6 base
module-init-tools.x86_64 3.9-25.el6 base
ncurses.x86_64 5.7-4.20090207.el6 base
ncurses-base.x86_64 5.7-4.20090207.el6 base
ncurses-devel.x86_64 5.7-4.20090207.el6 base
ncurses-libs.i686 5.7-4.20090207.el6 base
ncurses-libs.x86_64 5.7-4.20090207.el6 base
net-snmp.x86_64 1:5.5-57.el6_8.1 updates
net-snmp-libs.x86_64 1:5.5-57.el6_8.1 updates
net-snmp-utils.x86_64 1:5.5-57.el6_8.1 updates
nscd.x86_64 2.12-1.192.el6 base
nss.x86_64 3.21.3-2.el6_8 updates
nss-sysinit.x86_64 3.21.3-2.el6_8 updates
nss-tools.x86_64 3.21.3-2.el6_8 updates
ntp.x86_64 4.2.6p5-10.el6.centos.1 updates
ntpdate.x86_64 4.2.6p5-10.el6.centos.1 updates
ntsysv.x86_64 1.3.49.5-1.el6 base
openldap.x86_64 2.4.40-12.el6 base
openssh.x86_64 5.3p1-118.1.el6_8 updates
openssh-clients.x86_64 5.3p1-118.1.el6_8 updates
openssh-server.x86_64 5.3p1-118.1.el6_8 updates
pam.x86_64 1.1.1-22.el6 base
pango.x86_64 1.28.1-11.el6 base
passwd.x86_64 0.77-7.el6 base
pcre.x86_64 7.8-7.el6 base
perl.x86_64 4:5.10.1-141.el6_7.1 base
perl-Archive-Tar.x86_64 1.58-141.el6_7.1 base
perl-CGI.x86_64 3.51-141.el6_7.1 base
perl-Compress-Raw-Zlib.x86_64 1:2.021-141.el6_7.1 base
perl-Compress-Zlib.x86_64 2.021-141.el6_7.1 base
perl-Digest-SHA.x86_64 1:5.47-141.el6_7.1 base
perl-ExtUtils-MakeMaker.x86_64 6.55-141.el6_7.1 base
perl-ExtUtils-ParseXS.x86_64 1:2.2003.0-141.el6_7.1 base
perl-Git.noarch 1.7.1-4.el6_7.1 base
perl-IO-Compress-Base.x86_64 2.021-141.el6_7.1 base
perl-IO-Compress-Zlib.x86_64 2.021-141.el6_7.1 base
perl-IO-Socket-SSL.noarch 1.31-3.el6_8.2 updates
perl-IO-Zlib.x86_64 1:1.09-141.el6_7.1 base
perl-Module-Pluggable.x86_64 1:3.90-141.el6_7.1 base
perl-Net-SSLeay.x86_64 1.35-10.el6_8.1 updates
perl-Package-Constants.x86_64 1:0.02-141.el6_7.1 base
perl-Pod-Escapes.x86_64 1:1.04-141.el6_7.1 base
perl-Pod-Simple.x86_64 1:3.13-141.el6_7.1 base
perl-Test-Harness.x86_64 3.17-141.el6_7.1 base
perl-Time-HiRes.x86_64 4:1.9721-141.el6_7.1 base
perl-TimeDate.noarch 1:1.16-13.el6 base
perl-devel.x86_64 4:5.10.1-141.el6_7.1 base
perl-libs.x86_64 4:5.10.1-141.el6_7.1 base
perl-libwww-perl.noarch 5.833-3.el6 base
perl-version.x86_64 3:0.77-141.el6_7.1 base
pigz.x86_64 2.3.3-1.el6 epel
pinentry.x86_64 0.7.6-8.el6 base
pixman.x86_64 0.32.8-1.el6 base
portreserve.x86_64 0.0.4-11.el6 base
postgresql-libs.x86_64 8.4.20-6.el6 base
procmail.x86_64 3.22-25.1.el6_5.1 base
procps.x86_64 3.2.8-36.el6 base
python-pycurl.x86_64 7.19.0-9.el6 base
python-urlgrabber.noarch 3.9.1-11.el6 base
quota.x86_64 1:3.17-23.el6 base
redhat-rpm-config.noarch 9.0.3-51.el6.centos base
rpcbind.x86_64 0.2.0-12.el6 base
rpm.x86_64 4.8.0-55.el6 base
rpm-build.x86_64 4.8.0-55.el6 base
rpm-libs.x86_64 4.8.0-55.el6 base
rpm-python.x86_64 4.8.0-55.el6 base
rsync.x86_64 3.0.6-12.el6 base
rsyslog.x86_64 5.8.10-10.el6_6 base
ruby.x86_64 1.8.7.374-4.el6_6 base
ruby-devel.x86_64 1.8.7.374-4.el6_6 base
ruby-docs.x86_64 1.8.7.374-4.el6_6 base
ruby-irb.x86_64 1.8.7.374-4.el6_6 base
ruby-libs.x86_64 1.8.7.374-4.el6_6 base
ruby-rdoc.x86_64 1.8.7.374-4.el6_6 base
ruby-ri.x86_64 1.8.7.374-4.el6_6 base
samba.x86_64 3.6.23-36.el6_8 updates
samba-client.x86_64 3.6.23-36.el6_8 updates
samba-common.x86_64 3.6.23-36.el6_8 updates
samba-winbind.x86_64 3.6.23-36.el6_8 updates
samba-winbind-clients.x86_64 3.6.23-36.el6_8 updates
screen.x86_64 4.0.3-19.el6 base
shadow-utils.x86_64 2:4.1.5.1-5.el6 base
shared-mime-info.x86_64 0.70-6.el6 base
sqlite.x86_64 3.6.20-1.el6_7.2 base
sqlite-devel.x86_64 3.6.20-1.el6_7.2 base
strace.x86_64 4.8-10.el6 base
stunnel.x86_64 4.29-6.el6 base
subversion.x86_64 1.6.11-15.el6_7 base
sudo.x86_64 1.8.6p3-25.el6_8 updates
systemtap.x86_64 2.9-4.el6 base
systemtap-client.x86_64 2.9-4.el6 base
systemtap-devel.x86_64 2.9-4.el6 base
systemtap-runtime.x86_64 2.9-4.el6 base
sysvinit-tools.x86_64 2.87-6.dsf.el6 base
tar.x86_64 2:1.23-15.el6_8 updates
tcp_wrappers.x86_64 7.6-58.el6 base
tcp_wrappers-libs.x86_64 7.6-58.el6 base
tcpdump.x86_64 14:4.0.0-9.20090921gitdf3cb4.2.el6 base
tcsh.x86_64 6.17-35.el6_8.1 updates
telnet.x86_64 1:0.17-48.el6 base
time.x86_64 1.7-38.el6 base
tmpwatch.x86_64 2.9.16-6.el6 base
tzdata.noarch 2016j-1.el6 updates
udev.x86_64 147-2.73.el6_8.2 updates
unixODBC.x86_64 2.2.14-14.el6 base
unzip.x86_64 6.0-4.el6 base
upstart.x86_64 0.6.5-16.el6 base
util-linux-ng.x86_64 2.17.2-12.24.el6_8.1 updates
vim-common.x86_64 2:7.4.629-5.el6_8.1 updates
vim-enhanced.x86_64 2:7.4.629-5.el6_8.1 updates
vim-minimal.x86_64 2:7.4.629-5.el6_8.1 updates
wget.x86_64 1.12-8.el6 base
xinetd.x86_64 2:2.3.14-40.el6 base
xorg-x11-proto-devel.noarch 7.7-13.el6 base
xz.x86_64 4.999.9-0.5.beta.20091007git.el6 base
xz-libs.i686 4.999.9-0.5.beta.20091007git.el6 base
xz-libs.x86_64 4.999.9-0.5.beta.20091007git.el6 base
xz-lzma-compat.x86_64 4.999.9-0.5.beta.20091007git.el6 base
yum.noarch 3.2.29-75.el6.centos updates
yum-plugin-fastestmirror.noarch 1.1.30-37.el6 base
yum-plugin-priorities.noarch 1.1.30-37.el6 base
zip.x86_64 3.0-1.el6_7.1 base


#8

Thanks. A good long list of packages there that need updating on your system, including python which is probably related to the errors you are seeing.

I’m not sure who is acting as SysAdmin for your server, I’d suggest updating those packages though.


#9

HI ran the following already:

yum install gcc libffi-devel python-devel openssl-devel dialog

Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile

  • base: mirror.rackspace.com
  • elrepo: iad.mirror.rackspace.com
  • epel: mirror.us.leaseweb.net
  • extras: mirror.netdepot.com
  • updates: mirror.vtti.vt.edu
    449 packages excluded due to repository priority protections
    Setting up Install Process
    Package gcc-4.4.7-17.el6.x86_64 already installed and latest version
    Package libffi-devel-3.0.5-3.2.el6.x86_64 already installed and latest version
    Package python-devel-2.6.6-66.el6_8.x86_64 already installed and latest version
    Package openssl-devel-1.0.1e-48.el6_8.3.x86_64 already installed and latest version
    Package dialog-1.1-9.20080819.1.el6.x86_64 already installed and latest version
    Nothing to do

#10

Yes, that is just installing those 4 packages though - not updating the existing packages (which includes python related packages ). Your problem looks like a package related issue and not a Let’s Encrypt related issue, hence why I’m suggesting that your SysAdmin looks at it and updates those packages.


#11

I just ran the “yum update” command now but it doesn’t seem to have made a difference, still doing the same thing


#12

Can you paste the full log now of what you get when trying to obtain a certificate


#13

Eurika! I just removed the extention and reinstalled it, and got this message:

Information: Let’s Encrypt SSL certificate was successfully installed .


#14

The site still shows as unsecure, is there something else I should do still?


#15

What’s the domain name ?


#16

#17

Your page includes lots of information via http - hence why it’s “not secure” ( such as images and scripts).

whynopadlock.com/check.php

is a good site for finding out what those are. You are using wordpress by the look of the links, so you need to set in wordpress to use https as well.


#18

Ok, thank you so much for your assistance, much appreciated


#19

You’re welcome :slight_smile: Glad we got it sorted and you got a cert


#20

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.