I run a private server on a nonstandard port and do not let port 80 through firewalls

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: greencurtain.se
Specifically host la10cy02.greencurtain.se

I ran this command:

It produced this output:

My web server is (include version): service apache2 status
× apache2.service - The Apache HTTP Server
Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Sat 2023-12-02 10:55:44 +07; 1h 30min ago

The operating system my web server runs on is (include version): 5.15.0-89-generic #99-Ubuntu SMP

My hosting provider, if applicable, is: Selfhosted

I can login to a root shell on my machine (yes or no, or I don't know): Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): NO

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot --version
certbot 1.21.0

With Port 80 not available you will need to use either the DNS challenge or look at mod_md built into apache. Mod_md can use the tls-alpn challenge on Port 443. See the Apache docs or I like these GitHub docs


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.