Apache2 not using port 80

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: myndir.okkar.land

I ran this command: sudo certbot --apache -d myndir.okkar.land

It produced this output: Unable to find a virtual host listening on port 80 which is currently needed for Certbot to prove to the CA that you control your domain. Please add a virtual host for port 80.

My web server is (include version): Apache version 2.4.29

The operating system my web server runs on is (include version): Ubuntu 18.04

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

I am using Virtual servers through my router and port 80 and 443 is already in use for a different server and will be using different ports for this domain, is that not possible ?

1 Like

No, it is not. You may want to see if you can use DNS validation instead.

1 Like

Can you configure the server on port 80 to reverse proxy http://myndir.okkar.land/ to this server? It might be brittle, but it would work.

FYI, Certbot has an --http-01-port option. It allows you to change which port Certbot listens on. Let’s Encrypt will still connect to port 80, but it can help in complicated port forwarding setups.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.