Https directing to a different computer/server on the network

I installed certbot and it was one of the easiest so far, being a noob on web servers I am learning as I go. I choose to have all traffic redirected to https. I forwarded ports 80 and 443 to my server. What I get is the sign in page for my network controller on a different server. It had a port forward of 8443 and I killed that. Still when I try to go to this page I am directed to the wrong server. Right now it’s just a test page borrowed from my old web server but I should be able to access it.

Could use some guidance here.

My domain is:

I ran this command:

It produced this output: opened page to my network controller, UniFi.

My web server is (include version): Apache/2.4.38 (Debian)

The operating system my web server runs on is (include version): Debian

My hosting provider, if applicable, is: my own server.

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): 0.31.0

1 Like

Hi @Radjin

there is no real problem visible.

You have a new certificate ( ):

Issuer not before not after Domain names LE-Duplicate next LE
Let's Encrypt Authority X3 2019-08-24 2019-11-22,,,,,,, - 8 entries duplicate nr. 1

But your https in invisible, only your http port answers.

May be a wrong internal network configuration, may be a wrong router setup. There are a lot of errors possible.

Your port 80 answers, port 443 not -> looks like a router problem.

Or you have a wrong proxy configuration.

Hi @Radjin ! Welcome to the community!
I don't see port 443 open from my location.
Is there a Firewall, or some kind of routing going on behind the scenes?

How is your NAT config setup?
Are you running everything behind a single IP, ETC?
Need more info (at least for me)... Got me curious.

Awesome response…

Let’s see if I can work through it with your help.

Port 80 and 443 are both pointed at the web server. I would expect to at least get some sort of web server error rather than get the login page for the UniFi controller on a different computer. By the way, only is currently are active on https; I commented out the https code on the other configurations to work with one at a time. If you don’t get the UniFi login page that must be something to do with me logging in locally.

I activated my VPN and tried to see what I got and nothing is the answer.

Things to look for?



Thanks for the fast reply…

The only control is the UniFi gateway. None of the security is turned on (intrusion detection etc) and both ports 443 are 80 are pointed to the web server.

I am betting it’s going to be something really dumb only a noob would do. But it’s how we learn.


Check the output:

Domainname Http-Status redirect Sec. G 301 0.426 A 301 0.440 A -14 10.027 T
Timeout - The operation has timed out -14 10.027 T
Timeout - The operation has timed out

https has a timeout. So check the difference between your port 80 and your port 443 configuration.

I didn’t even see this reply when I logged, it scrolled off the screen.

Thanks for the reply though…

Ports 443 and 80 are both pointed to the web server. All security is turned off. the only access control is at the Unifi gateway. Yes, these are virtual sites so all of them accessed through one address.

If this works it will definitely be a noob problem…

I noticed that the setting for 443 was UDP not TCP. I changed it and waiting on it to reset.

Should it be set to both?


UDP can't work, https requires TCP. Now your https works, there is the content of your website.

1 Like

Works perfectly. Thanks for your help on this. I have never received such fast efficient help on any forum before.

Thanks to everyone who replied…



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.