Https redirects to box login page

My domain is: gdes.ga

I ran this command: sudo nano --apache -d gdes.ga

It produced this output: Congratulations! You have successfully enabled https://gdes.ga

My web server is (include version): Apache/2.4.38

The operating system my web server runs on is : Raspbian debian 10 (buster)

I can login to a root shell on my machine : yes

I’m using a control panel to manage my site : no

The version of my client is : certbot 0.31.0

Hi! I’m new to server computing, I bought a raspberry and installed apache. I made a port forwarding to both ports 80 and 443 on my box. I rented a domain name on freenom and indicated my public ip. My http version of the site seems to work so I tried to swich to https using certbot. My problem is that after getting the certificate, my site is redirected to the page https://gdes.ga/login.html, the login page of the box. I don’t understand why, I tried to make a 301 redirection but nothing seems to change.
Can you help me on this issue ?

I also tried the following test :

You should test your configuration at:
https://www.ssllabs.com/ssltest/analyze.html?d=gdes.ga

which gives me

Certificate name mismatch with mabbox.bytel.fr

which is the site I’m redirected to.

Best,
Gaetan

Is Home Assistant installed on the Rpi, or on a different device?

Hi thanks for your answer, I have a chromecast and a phillips hue bridge running on the same network, do you think it could be the problem ? On the pi there is only apache running.
Best, Gaetan

https://gdes.ga is a Lighttpd server connected to a Home Assistant installation.

If it is running on your Pi, that means you have two webservers running.

If it isn’t, then it means you have port 443 port forwarded to the wrong device.

Thank you for your support, it was in fact a problem related to my box : the remote access was using port 443. Just changing it on the admin page and it’s all good !
Best, Gaetan