Still reachable with http


#1

Please fill out the fields below so we can help you better.

My domain is:precode.eu

I ran this command: /

It produced this output: /

My operating system is (include version): Debian 8

My web server is (include version): Apache 2

My hosting provider, if applicable, is: Dedicated

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): yes

so hey guys, i installed the certi with this cerbot. But I can still reach my site with http. I chose at this installation Secure and not Easy


#2

It’s possible that existing bits of your apache configuration (including .htaccess files, if you use any) could interfere with the redirect that certbot sets up when you select the “Secure” option. Could you share your apache configuration, especially your vhost files?


#3

Where do I find this files?


#4

Here is the apache2.conf
http://pastebin.com/Bw4hqZxH


#5

I got 3 Files in my “sites-available” directory.

000-default-le-ssl.conf http://pastebin.com/hCagMb3C

000-default.conf http://pastebin.com/BiAG72kK

default-ssl.conf http://pastebin.com/0S658xV9


#6

There’s a line with ServerName p in 000-default-le-ssl.conf, and one with RewriteCond %{SERVER_NAME} =p in 000-default.conf. Is this some weird copy&paste error, or does it actually look like that in the file?

I suspect this should be ServerName precode.eu and RewriteCond %{SERVER_NAME} =precode.eu. I’m not entirely sure how that would have happened, though. I assume the files were not modified manually after you used certbot?

Either way, changing the lines and restarting apache should fix the redirect.


#7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.