Certbot: http > https redirect not working


#1

Just installed a certificate on new Debian Jessie using certbot --apache and installation was straight forward and completed OK.
http and https works nicely, thanks to everybody for their hard work.

However redirect from http to https did not work, yes i selected the install option, and raised an apache2 error:
[ssl:warn] [pid 735] AH01909: l:443:0 server certificate does NOT include an ID which matches the server name

After a bit of googling i edited /etc/apache2/sites-available/000-default.conf and hashed out the line:
RewriteCond %{SERVER_NAME} =l

Now everything works as expected.
Will this have any side effects?


#2

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.