How long to enable SSL Status for server pilot apps?


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: 26point2designs.com

I set up apps on my server (Server Pilot) to create development sites. Over time, it takes days for the SSL status to enable so I can actually go into my dev sites. I created 2 last Friday, and this option is still not deployed. Why is taking so long!!?


#2

Hi @jenvasko46,

If you tell us an example of one of the domain names, we can see whether the certificate has already been issued or not. However, we’re not involved with Server Pilot in any way (any application or service developer can use Let’s Encrypt to issue certificates, and we have no control over their technology). So I think you’ll get better help overall if you contact Server Pilot support.

https://serverpilot.io/support.html

If they do offer you more technical information but they can’t figure out the problem, you can also post the information here and we can try to help you analyze it.


#3

Thanks! I did actually contact them, and they had mentioned that it’s not a SP issue, but rather how long Let’s Encrypt takes to deploy them.

One of the apps is: devsite.26point2designs.com


#4

Let’s Encrypt is automated. The API issues a certificate, or returns an error message, the second a client asks it to.

What software are you using? Does it have a button or command to issue a certificate? What does it do? Is there an error message displayed or logged anywhere?

There may or may not be anyone on this forum familiar with ServerPilot’s software or platform.


#5

(Sorry in advance for being technically challenged…)


Normally there is a blue button/option to enable SSL (see screenshot), but I’m only getting the “SSL is not enabled” option. It didn’t used to be like this as most deployments took a few minutes. Perhaps I need to go back to Server Pilot and ask them? 26%20PM|690x466


#6

It’s true that there aren’t any A or AAAA records for those hostnames at the moment.

I’m not sure why, though. Maybe you have to add them in a control panel? Or it should be automated, but didn’t work for some reason?


#7

Weird because I add A records in Digital Ocean. Server Pilot now responds that it’s something with the Nginx set up. Thanks for your help!


#8

Solved. It had to do with the Nginx config. in Server Pilot. Now SSL certs are deploying in a timely manner. Thanks for your help!


#9

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.