How do I know which version of Linux I am running

My domain is: getensured.com

I ran this command: uname -a

It produced this output: Linux gator4204.hostgator.com 3.10.0-693.11.6.1.ELK.el6.x86_64 #1 SMP Tue Jan 23 10:30:30 MST 2018 x86_64 x86_64 x86_64 GNU/Linux

My web server is (include version): Linux

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: Hostgator

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): cPanel No Idea on Version Number

Which System do I select on the Certbot page?

Hi @JamesVanWaza,

Try running

cat /etc/lsb-release

@schoen I tried running, it and this is what I get.

Interesting! How about

cat /etc/*-release /etc/debian_version

Huh! And I guess Hostgator didn’t tell you what version of Linux it was either?

No they did not. What should I do?

I’m asking some colleagues for other suggestions.

1 Like

So, you could try running yum and apt and see if either of those package-management commands exist.

Our certbot-auto bootstrap script is not going to be able to bootstrap Certbot on your system.

You might want to try one of the bash clients from

They have relatively few dependencies and can often run on a wide range of operating systems without installing a lot of additional software. (Unlike Certbot, they don't attempt to edit your web server configuration to install the certificate after obtaining it, so you'll have to install the certificate in your web server yourself.)

1 Like

Looks like CentOS 6 to me.

1 Like

@schoen @sahsanu, I have setup using CentOS 6, but I get the following error for root.

@JamesVanWaza, that error is really strange. Show the output of this command:

namei -lm /usr/bin/sudo

Anyway, you can execute certbot-auto command without sudo, you are already root.

Also, /path/to/certbot-auto doesn’t mean actually typing “/path/to/certbot-auto” — it means typing in wherever you downloaded it on your system (which in this case is the current directory ., so you would run ./certbot-auto to start it out of the current directory).

2 Likes

I wouldn’t worry too much about the sudo thing. They’re probably running in a container.

Yes, I was thinking that could be a container or the user is using chroot.

this is what I get

That is ok, it is strange to have ishmaelsu as group on / but maybe you are chrooted so no problem. Then you should try the certbot command again, without sudo and using the right path… for example:

./certbot-auto --apache

As you are using CPanel, are you sure you can’t get the cert for your domain using the AutoSSL plugin?, maybe your hosting provider has not enabled it but it is worth to check it.

Cheers,
sahsanu

1 Like

And if they don’t have any support for Let’s Encrypt, it’s better to use acme.sh with CPanel:

Using certbot will install the certificate without CPanel’s knowledge, so it’s possible it could get overwritten when CPanel updates your web server configuration. acme.sh can automatically upload your certificate to your CPanel using its API, which is more reliable.

1 Like

@Patches @sahsanu

I started installing but I got this error, what does it mean.