How do I clean up a Domain in Ubuntu 16 / Plesk Onyx?


#1

Please fill out the fields below so we can help you better.

My domain is: www.liesenfeld.media

I ran this command: I messed up

It produced this output: Cannot remove or reissue the certificate

My operating system is (include version): Ubuntu 16 with Plesk Onyx

My web server is (include version): Apache2

My hosting provider, if applicable, is: Strato

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Plesk Onyx

Hi guys,

damn, I really messed up.
I wanted to issue a cert in Plesk for Liesenfeld.media, but did so with the wrong domain. I tried to correct it, by doing it for the right domain. Didn’t issue, because it was already on the server.
I panicked and deleted
/opt/psa/var/modules/letsencrypt/etc/live/liesenfeld.media/
and
/opt/psa/var/modules/letsencrypt/etc/renewal/liesenfeld.media/
and deleted the entry in the psa database 'certificates’
Found out, that I could have deleted the certificate easily inside plesk.
Now I cannot reissue a new certificate for Liesenfeld.media.
How can I manually erase all traces of the corrupted Liesenfeld.media-Certificate, so that I can reissue the cert anew?


#2

Recommend mentioning “Plesk” in your title if you’re able to edit it, since right now someone with Plesk knowledge giving the forums a cursory glance won’t be likely to click this post, and I think Plesk knowledge is what’s needed here.


#3

Thnx. Done :wink:
Anyone can help me?


#4

have a look at the source code and devblog



#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.