Home page is not Secure but all other pages are


#1

I appreciate very much the help from Let’s Encrypt. I am hoping someone can help me with this problem.

Miralomaregional.xyz


#2

Your home page is reachable via https:

https://miralomaregional.xyz/

Do you want to get redirected from http to https automatically, or what is your question?


#3

I undoubtedly misunderstand something here. The browser maybe the issue.
The attached images show the home page browser message for some reason says
for some reason it is not encrypted. All of the other pages are encrypted
showing a different message.

Thank you for your response.


#4

Hi,

This means your site is not fully secure. You’ll need to convert all http link to https to remove this message.

What web server are u using?


#5

it is a Google Cloud Platform. I use a Bitnami Launchpad for Google Cloud.


#6

Okay.

I see that your website is using Apache.
Can you try to locate your Apache file in server and use this guide to edit the .htaccess file (to enable https?)

https://www.namecheap.com/support/knowledgebase/article.aspx/9821/38/redirect-to-https-on-apache

Thank you.


#7

This error could be related to mixed content (HTTP resources inside an HTTPS page). That’s why @stevenzhu says

You could also try checking with https://www.whynopadlock.com/ to identify mixed content problems on the site.


#8

so,
this
<VirtualHost *:80>
ServerName www.yourdomain.com
Redirect permanent / https://www.yourdomain.com/


ServerName www.yourdomain.com
DocumentRoot /usr/local/apache2/htdocs
SSLEngine On

should be written to my

“/usr/local/apache2/htdocs” file?


#9

The page he visit is logged-in user only…

Hence i believe no scanner can visit the page.


#10

Oh, I didn’t realize that! So you would have to look for HTTP links yourself (perhaps with “View Source” or “Page Info”).


#11

If your apache vhost file is in there, then yes.


#12

easy enough I will try this thank you both and if I have trouble I will contact you again


#13

let's%201
I did this…


#14

and this…

But my home page still shows not encrypted message


#15

However, I can’t seem to locate a .htaccess file. I looked in several locations where I thought it should be…


#16

I also do not have these modules installed:
a2enmod rewrite
a2enmod ssl


#17

resolved the issue. No need to reply. Thanks


#18

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.