Is it possible to cause after install the let's encrypt makes the website beginning without https redirect to the homepage?


#1

Hello, everyone, is there any possibility to install the let’s encrypt and start it, it will cause the original http URL, after submitting to the google sitemap some https of the URL is missing (as shown below), the link will automatically lead back to the home page. Does let’s encrypt have the function to return the wrong link in the domain to the home page?


#2

I’m using this for nginx
server {
listen 80 default_server;
listen [::]:80 default_server;
server_name _;
location ^~ /.well-known/acme-challenge/ {
default_type “text/plain”;
root /var/www/challenge;
}
location / {
return 301 https://$host$request_uri;
}
}
and for apache,
https://www.tecmint.com/redirect-http-to-https-on-apache/


#3

Hi @momodan

it’s Googles decision how to present the result. And I don’t understand your question.

Google shows that the site is secure. That doesn’t mean that all links go to the root.

That’s a thing of Google, not of Letsencrypt or another CA.


#4

It’s hard to understand this for sure without knowing your domain name. But I agree with @JuergenAuer that Google controls how results are presented on Google.

It seems like it’s confusing that Google is returning any HTTP links to your site after you’ve added redirects from HTTP to HTTPS on your web server, since Google should also be following those links. So maybe Google has just not crawled your full site since you added those links? I assume that it takes some time after uploading the sitemap before the new crawl happens and before it’s reflected on the Google search.

If you go to one of those HTTP result links in your browser, do you get redirected to HTTPS correctly? If so, it’s probably just a delay on Google’s part in updating its own database.


#5

Here is a reason why Google won’t show the https links:
When the redirects fail to show the correct content searched for.
[Like: When all http URLs are being forwarded to the plain https root.]
[http://my.site/folder/cool/content.html >301> http://my.site/]

But, as others have said, without more information (like a sample URL or domain name), it is impossible to give you any accurate information nor good advice.


#6

Because the situation occurs after I install Letsencrypt and submit the sitemap, and there is no 301 redirect software installed on my host, so the system should not automatically redirect invalid URLs, so I will guess if Letsencrypt will be invalid. URL-oriented home page feature setting

No, all URLs without http or https at the beginning are directed to the home page. Only URLs that display https will link properly.。
I have installed Letsencrypt for almost two weeks, submitted a new sitemap and deleted the old sitemap for almost a week. I don’t know if the speed of google updates is so slow.

This is my website money.geggg.com Sincerely hope that you can visit and provide your opinion. thank you very much


#7

I have added a new sitemap after deleting the old sitemap, so it should not link to the new URL error. And I don’t have any 301 redirect software installed on my host.So, the system should not automatically redirect invalid URLs.

This is my website money.geggg.com Sincerely hope that you can visit and provide your opinion. thank you very much


#8

Hi @momodan

first, your nameserver entries are inconsistent ( https://check-your-website.server-daten.de/?q=money.geggg.com )

Host T IP-Address is auth. ∑ Queries ∑ Timeout
money.geggg.com A 114.35.251.27 yes 1 0
AAAA yes
www.money.geggg.com Name Error yes 1 0
money.geggg.com A 118.99.246.252 no

There are two ip addresses, one authoritative, one not. Perhaps that’s only a time problem.

There are different http status:

K http://money.geggg.com/ 114.35.251.27, Status 404
http://money.geggg.com/ 118.99.246.252, Status 302
configuration problem - different ip addresses with different status
K https://money.geggg.com/ 114.35.251.27, Status -14
https://money.geggg.com/ 118.99.246.252, Status 200
configuration problem - different ip addresses with different status

But really relevant:

Domainname Http-Status redirect Sec. G
http://money.geggg.com/
118.99.246.252 302 https://money.geggg.com/ 0.657 A
http://money.geggg.com/
114.35.251.27 404 0.487 M
Not Found
https://money.geggg.com/
114.35.251.27 -14 10.023 T
Timeout - The operation has timed out
https://money.geggg.com/
118.99.246.252 200 5.630 B
http://money.geggg.com/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de
118.99.246.252 302 https://money.geggg.com/ 0.613 A
http://money.geggg.com/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de
114.35.251.27 404 0.484 A
Not Found

http + 118.99.246.252 has a wrong redirect - http://money.geggg.com/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de redirects wrong to https://money.geggg.com/.

Checking your site manual, there is the same wrong redirect:

D:\temp>download http://money.geggg.com/?p=733 -h
Content-Length: 147
Content-Type: text/html; charset=UTF-8
Date: Sun, 17 Feb 2019 16:52:59 GMT
Location: https://money.geggg.com/
Server: Microsoft-IIS/8.5
X-Powered-By: ASP.NET

Status: 302 Redirect

805,00 milliseconds
0,81 seconds

D:\temp>download https://money.geggg.com/?p=733 -h
SystemDefault
SSL-Zertifikat is valide
Link: <https://money.geggg.com/index.php?rest_route=/>; rel="https://api.w.org/",<https://money.geggg.com/?p=733>; rel=shortlink
Content-Type: text/html; charset=UTF-8
Server: Microsoft-IIS/8.5
X-Powered-By: PHP/5.5.38,ASP.NET
Date: Sun, 17 Feb 2019 16:53:18 GMT
Content-Length: 26823

Status: 200 OK

3958,10 milliseconds
3,96 seconds

http has a wrong redirect to https, but it’s a 302, not a 301.


So check your configuration to find this redirect and fix it. http + /filename -> https + /filename with a 301.


#9

I am so appreciate about @JuergenAuer for doing so many tests for me, it makes me have a direction to fix the problem. May I ask , what are the possibility reasons for the 302 error? Is it the DNS or the server I should modify? If I do as @orangepizza said by modifying the htaccess file , can I solve this problem? Sincerely for your reply.


closed #10

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.