"hello-world" runs; "snap install --classic certbot" seg faults

My domain is:
mail.tryx.org, mail.tclc.org

I ran this command:
snap install --classic certbot

It produced this output:

snap install --classic certbot

error: cannot perform the following tasks:

  • Run configure hook of "certbot" snap if present (run hook "configure":

fatal error: unexpected signal during runtime execution
[signal SIGSEGV: segmentation violation code=0x1 addr=0x0 pc=0x0]

My web server is (include version):
Zimbra mail server, so nginx, and apache. nginx serves the mail, and apache serves the users.

nginx version: nginx/1.7.1
Apache/2.4.6 (CentOS)

The operating system my web server runs on is (include version):
Centos 7

I can login to a root shell on my machine (yes or no, or I don't know):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

certbot --version

snap 2.57.6-1.el7
snapd 2.57.6-1.el7
series 16
centos 7
kernel 3.10.0-862.14.4.el7.x86_64

On the assumption that there might be something wrong with my machine, I have already completely removed both "snapd" and "certbot" and re-installed. This error persists across a clean re-install, so it is either a remarkable coincidence, corrupt library that is already present, or a problem with "certbot".

Thanks for the help,



Could the seg fault be related to this perl module problem?


CentOS runs snap?


Is there a "non-snap" installation option? I think I'd go for that ...

I don't think so. I am still trying to install certbot, and the problem you highlight is during certificate creation/installation.

1 Like

Try yum.


Interestingly, that worked. Thanks for the help. You got me out of a sticky problem. My zimbra mail server is down with an expired certificate.

1 Like

Is Zimbra mail still down?


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.