Certbot via snap on RHEL 8 arm64 gives SEGV

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:
N/A at this point

I ran this command:
I installed snapd and certbot as directed for CentOS 8 (Certbot Instructions | Certbot) and all seemed fine but whenever I try to run certbot It just segvs:

admin@jfoci:~$ sudo certbot --apache
zsh: segmentation fault sudo certbot --apache

It produced this output:

See above. The sego occurs regardless of how I invoke certbot.

My web server is (include version):

Apache 2.4.37

The operating system my web server runs on is (include version):

Oracle Linux 8.6 (RHEL 8.6)
Linux jfoci 5.4.17-2136.307.3.5.el8uek.aarch64 #2 SMP Thu May 26 18:21:01 PDT 2022 aarch64 aarch64 aarch64 GNU/Linux

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):
No idea - it segvs when I run this command.

1 Like

Hi @ChrisJ60, and welcome to the LE community forum :slight_smile:

Please show:
which certbot


If your server is on Oracle cloud, there's an issue with their aarch64 CPUs and snapd: Segmentation fault · Issue #9138 · certbot/certbot · GitHub.


Aha, thank you! Yes, this is an arm64 Ampere system in Oracle Cloud.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.