Certbot no longer working

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:
certbot certificates

It produced this output:
2023/07/30 06:00:25.245092 system_key.go:129: cannot determine nfs usage in generateSystemKey: cannot parse /etc/fstab: expected between 3 and 6 fields, found 12 Saving debug log to /var/log/letsencrypt/letsencrypt.log

My web server is (include version):
Debian 5.10.179-1

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

I get the same error as above when I run certbot --version

I only noticed this as I tried to load up a site on this server and got a This site can’t provide a secure connection error. Then I logged in and ran certbot certificates to see there was an issue ... it throws the same error with sudo cerbot --apache

any help would be appreciated :slight_smile:

@_az This error is apparently generated by snapd and I think was fixed upstream in snapd at some point... do you happen to know anything more about this?

Hi @po_pm, could you please also show the complete output of this command?

snap --version

1 Like

Please tell me that was a TYPO:


@rg305 It's probably the Linux kernel version rather than the Debian release version. I was confused about the distinction between distribution versions and kernel versions for about a year after I first started using Linux.

The snap --version output should include the kernel version and distribution version. (Other methods to find these separately are uname -a and lsb_release -a, but since we're also interested in the version of snapd, I think snap --version is the best single command to use.)


Probably, yes, 5.10.179 corresponds to the linux-image-amd64 package in Debian Bullseye.

1 Like

Hey @schoen (see below)
snap 2.59.5
snapd 2.59.5
series 16
debian 11
kernel 5.10.0-23-amd64

Oops @rg305, yes indeed :sweat_smile:

1 Like

OK, looks like those are all current!

This error would probably go away if you could install Certbot via a method other than snap, but I'm reluctant to tell you do that because snaps are the method that the Certbot developers have been trying to get most users to use!

I hope @_az will be able to take a look at this.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.