Certbot missing something

My domain is: sapphire.mvdavid.com

I ran this command: certbot (all arguments produce same result)

It produced this output:

Traceback (most recent call last):
File "/usr/bin/certbot", line 33, in
sys.exit(load_entry_point('certbot==1.22.0', 'console_scripts', 'certbot')())
File "/usr/bin/certbot", line 25, in importlib_load_entry_point
return next(matches).load()
StopIteration

My web server is (include version): Apache httpd 2.4.52

The operating system my web server runs on is (include version): Linux kernel 5.15.17 Fedora 35

My hosting provider, if applicable, is: Linode

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): from fedora, certbot-1.22.0-1.fc35.noarch, --version doesnʻt work.

Hi @zvyov7al and welcome to the LE community forum :slight_smile:

I'd try uninstalling and then reinstalling certbot.
I'm not familiar with Fedora, which installation guide did you follow?

3 Likes

I am not sure any more. I had it working since it first came out, and it was still working on one of my two hosts. Today I tried the instructions for using snapd, and that seems to work in both instances. I will stick with that.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.