FreePBX 13 fails to generate certificate: No registration

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: s-reeves-webrtc.forge-cloud.com

I ran this command: FreePBX generate request

It produced this output: There was an error updating the certificate: HTTP Challenge for s-reeves-webrtc.forge-cloud.com is not available. Whole response: {“type”:“urn:acme:error:unauthorized”,“detail”:“No registration exists matching provided key”,“status”:403}

My web server is (include version): Apache 2.2

The operating system my web server runs on is (include version): Centos 7

My hosting provider, if applicable, is: N/A

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): FreePBX 13

i am going to suggest you take this to the freepbx forums

i have had a look and other have had issues

https://wiki.freepbx.org/display/FPG/Certificate+Management+User+Guide

although it looks like freepbx use certbot ufortunately they have put their own layer on top which is why they would be the best to help

Andrei

Hello,

Thank you for the feedback. I have searched the FreePBX forums extensively but no one has been able to assist thus far.

Does anyone else here have any experience with this issue?

There is this thread on the FreePBX forums which indicate that this is an issue with LE, and that people are being directed from here back there…

Could I please get an answer? Is this a known issue that is being worked on?

Reading the linked article in the FreePBX-community, it seems this has been fixed in their certman.

I’m afraid this is an inaccurate conclusion. There’s no issue related to finding registrations by key on the Let’s Encrypt side. This would be a result of a bug with the ACME client that FreePBX is using. Hopefully @bytecamp is correct that it has since been fixed upstream by the FreePBX developers.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.