Failed to generate SSL certificate

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:
sudo certbot --apache

It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log

Which names would you like to activate HTTPS for?


Select the appropriate numbers separated by commas and/or spaces, or leave input
blank to select all options shown (Enter 'c' to cancel): 1
Requesting a certificate for

Certbot failed to authenticate some domains (authenticator: apache). The Certificate Authority reported these problems:
Type: connection
Detail: Fetching Timeout during connect (likely firewall problem)

Hint: The Certificate Authority failed to verify the temporary Apache configuration changes made by Certbot. Ensure that the listed domains point to this Apache server and that it is accessible from the internet.

Some challenges have failed.
Ask for help or search for solutions at See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.

My web server is (include version):
Apache/2.4.6 (CentOS)

The operating system my web server runs on is (include version):
CentOS Linux 7 (Core)

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):
certbot 1.21.0

@KJ5186 Welcome to the community!

A connection to your site on port 80 is required for the http challenge. It looks to me like both port 80 and 443 are not open to your server. Check your router and/or firewall(s) to ensure these are open.

Try this for testing changes:

Click re-run test for fresh attempt.


Hi Mike, thank you for you reply. The website itself can be accessed. Wondering does it mean the port 80 is opening?

1 Like

Not from the public internet. Are you trying just inside your own network?

I just retried Lets Debug and got same result as before. Did you check your router and/or firewalls? Do you have a hosting provider or is this self-hosted?

If Lets Debug cannot see your server you will not be able to get Lets Encrypt certs using http challenge


Yes, it was due to firewall issue. It works now. Thank you @MikeMcQ


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.