Error when I create a certificate form my site

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: www.profforma-gpm.it

I ran this command: create new certificate

It produced this output:

Error: Unable to generate an SSL / TLS Let’s Encrypt certificate for profforma-gpm.it. Domain authorization failed.
Details
Invalid response from https://acme-v02.api.letsencrypt.org/acme/authz-v3/13591554733.
Details:
Type: urn: ietf: params: acme: error: dns
Status: 400
Detail: No valid IP addresses found for profforma-gpm.it

My web server is (include version): Plesk Onix 17.8.11

The operating system my web server runs on is (include version): Apache2

My hosting provider, if applicable, is: Aruba

I can login to a root shell on my machine (yes or no, or I don't know): Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): Yes

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): I don't know

Pretty much exactly what it says: profforma-gpm.it doesn't have an IP address. You probably want to either have your certificate only for www.profforma-gpm.it if you want your users to only be able to access your site with the www. in front, or you want to assign an IP address in your DNS for profforma-gpm.it if you want users to be able to get to your site without the initial www.

A lot of people expect both the www. and non-www. versions of a site to do the same thing, but there's nothing in the Internet architecture that requires that to be the case, so you end up needing to set a lot of things up twice. :slight_smile:

Hi Peter,
In reality, an address without www., Pa, apparently, for Let'sEncrypt does not exist in the DNS management of the provider. No problem. I move the host address to www.profforma-gpm.it So it should work. I'll let you know.

But not PA, sorry. :slight_smile:

Hello Peter,
I checked. In the host the domain is already indicated as www.profforma-gpm.it. So why is the IP not seen? The site is visible online normally.

Resolved. I changed settings by removing wildcard. Graxie you can close the ticket.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.