Error Registering account SSL

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: /usr/local/centovacast/sbin/set_secure

It produced this output:
Dispatching certificate request ...
Note: this may take a few minutes, especially while "Trying to solve HTTP-01";
please be patient.

| [INFO] acme: Registering account for admin@
| Could not complete registration
| acme: error: 400 :: POST :: :: urn:ietf:params:acme:error:invalidContact :: Error creating new account :: contact email "admin@" has invalid domain : The ACME server can not issue a certificate for an IP address, url:
| ! Error: Failed


My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): (

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

Welcome @informaticarem

But, I don't think we'll be able to help you with this. You should probably ask Centova who provided and support the set_secure script you are using.

It looks like you entered your correct information but that the script replaced your domain name with your IP. You must use domain names (and not the IP) for Let's Encrypt certs - both for email addresses and for cert requests. I do not know why Centova would do that.


Try adding quotes around your email address:

/usr/local/centovacast/sbin/set_secure \ \

Hi @rg305 @MikeMcQ , same error, im tried change email to Gmail and nothing changed

Unless their script is legible - and you can fix it yourself...


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.