Error on renewal certificate

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:
I ran this command:
./certbot renew
It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log

Processing /etc/letsencrypt/renewal/

Cert is due for renewal, auto-renewing…
Plugins selected: Authenticator apache, Installer apache
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for
Waiting for verification…
Cleaning up challenges
Attempting to renew cert ( from /etc/letsencrypt/renewal/ produced an unexpected error: Failed authorization procedure. (http-01): urn:ietf:params:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from “\n\n404 Not Found\n\n

Not Found

\n<p”. Skipping.
All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/ (failure)

All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/ (failure)

1 renew failure(s), 0 parse failure(s)


My web server is (include version):
Server version: Apache/2.4.25 (Debian)
Server built: 2017-09-19T18:58:57
The operating system my web server runs on is (include version):
NAME=“Debian GNU/Linux”
VERSION=“9 (stretch)”
My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):
I’m using a control panel to manage my site (no, or provide the name and version of the control panel):No

What’s this show?

apachectl -t -D DUMP_VHOSTS


1 Like

apachectl -t -D DUMP_VHOSTS
AH00112: Warning: DocumentRoot [/var/www/html/dictaminacion] does not exist
VirtualHost configuration: (/etc/apache2/apache2.conf:165)
*:443 (/etc/apache2/sites-enabled/000-default-le-ssl.conf:2)
*:80 (/etc/apache2/sites-enabled/000-default.conf:1)


I found the issue, there was a wrong VirtualHost on apache conf, I remove it and I renwe the cert succesfully


Hi @edgarhammer

but not complete. You have two ip addresses, your www - version has a different ip (checked with my online tool - Make your website better - DNS, redirects, mixed content, certificates ):

Domainname Http-Status redirect Sec. G 301 0.366 A 200 0.686 H 200 9.023 A 200 7.180 N
Certificate error: RemoteCertificateNameMismatch

And your www-version has the wrong certificate.
13.01.2019 - 1 entry

So if a visitor uses your www - version, he can't see your page.

  • Remove the www dns entry (not really good)
  • create a certificate with the www domain name (better)
  • create one certificate with both domain names (www + non-www)

Thanks a lot, we will check the other domain

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.