Error message: Webroot does not exist

My domain is:

My web server is (include version): cPanel Linux hosting

My hosting provider, if applicable, is: Godaddy

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): cPanel

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): Dont know.

Command line asked: “Input the webroot for
I answered the following in the command line (which is my document root that I found in my c-panel): /public_html/
Command line output: Input the webroot for

Thank you for any help!

In a cPanel context, your webroot is actually /home/USERNAME/public_html/ , making sure to substitute your actual cPanel username for USERNAME.

The short form may also work:

1 Like

Thanks for replying so quickly!

Your reasoning sounds correct, and I tried it, both the long and short form. Still I get the same output “does not exist or is not a directory”.
The only step that I have done so far during your guide that I am a bit uncertain about is that I choosed “none of above” in the field asking for “My http website is running on”, since I run on cpanel linux.

What do you suggest I do now?

Well, let’s take a couple of steps back:

Certbot isn’t built to work in shared hosting environments, like GoDaddy’s cPanel hosting.

In a shared hosting environment, the ideal outcome is that your host integrates Let’s Encrypt for you, so you don’t need to do anything. cPanel actually has a feature called AutoSSL that automatically does all the SSL things for you.

Unfortunately, GoDaddy have conflicting commercial interests, since they are a certificate authority themselves, and sell these certificates for profit. So they disable AutoSSL and don’t provide a convenient way to use Let’s Encrypt.

That I know of, the “next best” approach, made possible if you have SSH access, is to use There is a guide to using it in a shared hosting environment here:

Maybe take a look at that?


Great, I looked into this, and there is one step I dont get unfortunately if you have time for it… So my cPanel provider (godaddy) cannot provide me with the server address to connect to ssh. What would you suggest me to do?

1 Like

This sounds like your hosting plan isn’t appropriate for this solution, or else your support isn’t being forthcoming with the information you need. Is it clear to you whether you have a hosting plan that includes SSH access?

Hmm. The error message and input prompts from the original post appear to be generated by Certbot.

@lapqal. were you running Certbot earlier on your GoDaddy hosting service, or on your own computer?

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.