SOLVED - Can't create certificate on Certbot


#1

Hi,
I was installing Next Cloud 13, through a vmware image, when the installer was unable to install the certificates.
After the installation, I tried again with the following command:
“sudo certbot --apache”
and got this error message:
“Client with the currently selected authenticator does not support any combination of challenges that will satisfy the CA.”
When I googled the error I found this explanation (https://github.com/certbot/certbot/issues/5405#issuecomment-356498627), and inputed, as suggested, the following command:
“sudo certbot --authenticator webroot --installer apache”
which produced the following output:
"Select the webroot for tralha.eu:
1: Enter a new webroot
Press 1 [enter] to confirm the selection (press ‘c’ to cancel): "

My problem now is that I’m not quite sure what a webroot is. Again I googled and found out that is the directory where the files to be shared are (What is webroot?).
So I inputed the path to the directory like so: “/home/miguel/Nextcloud”, and got this error message:
“** Invalid input **
Press 1 [enter] to confirm the selection (press ‘c’ to cancel)”

I don’t know what I should do next, I suspect I’m not understanding correctly what a webroot is, and that may be the problem.

Any help would be greatly appreciated

My domain is: tralha.eu

I ran this command: sudo certbot --authenticator webroot --installer apache

It produced this output:
Select the webroot for tralha.eu:
1: Enter a new webroot
Press 1 [enter] to confirm the selection (press ‘c’ to cancel):

My web server is (include version): Apache 2.4.27.-2

The operating system my web server runs on is (include version): Deepin 15.4

My hosting provider, if applicable, is: a2hosting

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no


#2

It looks like your site already has an LE cert:
https://www.ssllabs.com/ssltest/analyze.html?d=tralha.eu

Try:
sudo certbot certificates


#3

Hi rg305,
after inputing the command it answers: “No certs found.”


#4

Your domain is hosted on a cPanel server that has already taken care of SSL for you.

For what reason are you trying to issue another certificate with Certbot? Are you deploying the site somewhere else?

FWIW,

  • The error you experienced with --apache relates to you having an old version of Certbot. You should upgrade to the latest.
  • You may be able to use --apache --preferred-challenges http to work around it.

#5

Thanks for taking the time to answer. I’m not deploying anywhere else, I didn’t realize that the certificate was already there.


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.