Error: Let's Encrypt validation status 400

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain

I ran this command:/usr/local/vesta/bin/v-add-letsencrypt-domain admin

It produced this output:Error: Let’s Encrypt validation status 400

My web server is (include version):

The operating system my web server runs on is (include version):Ubuntu 16.04

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):vestacp

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

You should go digging for any relevant logs, because that single error code didn’t come from let’s encrypt and tells us very little.

But you have a certificate issued today, just use that:


But there were no relevant more logs it just said this error when I ran the above mentioned command. I mean atleast can i know is there anything wrong with domain or anything else would be helpful.

can you check if the domain has a certificate already? if it does, use that.

Any easier way to check that?

You do realize that your website is currently served over https with a certificate issued two hours ago, do you?


Hi @varun98

check your domain -

There is a new certificate:

Issuer not before not after Domain names LE-Duplicate next LE
Let’s Encrypt Authority X3 2020-03-27 2020-06-25, - 2 entries duplicate nr. 1

And you use it:
expires in 90 days, - 2 entries 

Only problem:

Your VestaCP-port

doesn’t use that certificate.

Hi any idea how to configure that?

There should be some settings in the vesta web interface.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.