Error in subdomain A DNS record


#1

I own “sert.co.in” and want to renew a certificate for “in.sert.co.in

When I try to renew it, I get:

Processing /etc/letsencrypt/renewal/in.sert.co.in.conf
2016-03-09 22:03:16,794:WARNING:letsencrypt.cli:Attempting to renew cert from /etc/letsencrypt/renewal/in.sert.co.in.conf produced an unexpected error: Failed authorization procedure. in.sert.co.in (http-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: Could not connect to http://in.sert.co.in/.well-known/acme-challenge/7_abJXe3uW5yd-1jhrapwyEQZTDrR2EFdWzdEJJcBCI. Skipping.

The following certs could not be renewed:
/etc/letsencrypt/live/in.sert.co.in/fullchain.pem (failure)
** DRY RUN: simulating ‘letsencrypt renew’ close to cert expiry
** (The test certificates above have not been saved.)
1 renew failure(s), 0 parse failure(s)

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: in.sert.co.in
    Type: connection
    Detail: Could not connect to http://in.sert.co.in/.well-known/acme-
    challenge/7_abJXe3uW5yd-1jhrapwyEQZTDrR2EFdWzdEJJcBCI

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

As far as I can tell, my Linode server is using IPV6 when I try pinging it:
ping in.sert.co.in
PING in.sert.co.in(node01 (2600:3c01:e000:87::2)) 56 data bytes
64 bytes from node01 (2600:3c01:e000:87::2): icmp_seq=1 ttl=64 time=0.047 ms

As letscrypt doesn’t seem to be IPV6-ready, I want to assume it’s something IPV6 related, although it also seems specific to this particular domain, as I have other pointing to the same server that are renewing fine (still doming dry-run)

Any hints or anyone with similar issues?


#2

Impatient as I am, I tried disabling IPV6 on my linode temporarily, which didn’t seem to have worked,
so I removed IPV6 records from domain zone, which also didn’t seem to have any effect.

then I tried:

systemctl stop nginx && letsencrypt certonly -d in.sert.co.in && systemctl restart nginx

IMPORTANT NOTES:

  • Congratulations! Your certificate and chain have been saved at
    /etc/letsencrypt/live/in.sert.co.in/fullchain.pem. Your cert will
    expire on 2016-06-08. To obtain a new version of the certificate in
    the future, simply run Let’s Encrypt again.

  • If you like Let’s Encrypt, please consider supporting our work by:

    Donating to ISRG / Let’s Encrypt: https://letsencrypt.org/donate
    Donating to EFF: https://eff.org/donate-le

and it’s working now.