Certbot - IPV6 Addresses on Domains Means Renewals Don't Work

Please fill out the fields below so we can help you better.

My domain is: kanboard.hypothetical.net (and few dozen others, all same error)

I ran this command:

./letsencrypt-auto renew

It produced this output:

------------------------------------------------------------------------------- Processing /etc/letsencrypt/renewal/kanboard.hypothetical.net.conf

Cert is due for renewal, auto-renewing…
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for kanboard.hypothetical.net
Waiting for verification…
Cleaning up challenges
Attempting to renew cert from /etc/letsencrypt/renewal/kanboard.hypothetical.net.conf produced an unexpected error: Failed authorization procedure. kanboard.hypothetical.net (http-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: Could not connect to kanboard.hypothetical.net. Skipping.

My web server is (include version): nginx/1.10.1

The operating system my web server runs on is (include version): Debian 7.3

My hosting provider, if applicable, is: Ramnode

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No

I have been renewing certs regularly since 2015, but since around March 30, none of my domains will renew, though I have made no changes to the server or DNS configuration. My domains resolve from locations I am able to test from, and I am able to access a test file in .well-known/ on https and http ports (80, 443). Currently I am able to access these files:

curl "http://kanboard.hypothetical.net/.well-known/test"
This is a Test file with no extension.

curl "https://kanboard.hypothetical.net/.well-known/test"
This is a Test file with no extension.

curl "https://kanboard.hypothetical.net/.well-known/test.txt"
This is a test file with the .txt extension.

curl "http://kanboard.hypothetical.net/.well-known/test.txt"
This is a test file with the .txt extension.

I am using letsencrypt-auto from the master branch of https://github.com/letsencrypt/letsencrypt.git (certbot 0.14.2)

Thanks in advance for any insight!

Hi @kennric,

This is potentially due to

You have an AAAA record, but your site doesn't seem to answer in IPv6. It will need to be configured to respond to IPv6 requests as long as you are advertising IPv6 support.

Aha! That makes sense, I haven’t tested ipv6 since initial setup, so perhaps it’s been broken for a while. I don’t have good access to ipv6 networks for testing, other than from the web server itself.

I’ll test that out, thanks!


Should be:

So your test should be:
which currently fails 404

Thanks @schoen, ipv6 was indeed the problem. My domains and web server were set up correctly, but there seems to be some kind of IPv6 routing issue with the hosting provider currently. Turning off IPv6 for the domains allowed letsencrypt-auto renew to authorize.

Thanks @rg305, my nginx is configured to allow everything below .well-known, and .well-known/acme-challenge worked as well, but I didn’t think to paste those tests into the issue and had already removed the subdirectory before pasting. Sorry for muddying the waters with that.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.